Unable to override default retroarch.cfg controls

Home Forums RetroPie Project Everything else related to the RetroPie Project Unable to override default retroarch.cfg controls

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 1 year, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #98405
    Profile photo of link2803
    link2803
    Participant

    Hi all,

    I’m hoping someone can help me here before I start tearing my hair out! I love RetroPie and have everything set up exactly how I want except one specific issue which is bugging me.

    I’m using a wireless 360 controller with no problems at all over a majority of systems but I’m wanting to remap a few buttons, specifically the A and B buttons for NES and Gameboy.

    No matter what I do, I can’t seem to override the “input_player_*_btn” values in the “configs/all/retroarch.cfg” file. When I edit the system-specific file (“configs/<system>/retroarch.cfg”), RetroArch reads all other override values – I’ve tested this with the “video_shader_enable” value which reads correctly – but not remapping commands.

    I’ve enabled / disabled “input_remap_binds_enable”, “input_autodetect_enable” and “core_specific_config” but to no effect. I can remap within RetroArch’s GUI and this works fine until I exit and re-load whereby the default controls are reset.

    For clarity, here is my nes/retroarch.cfg file:

    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    # All settings made here will override the global settings for the current emulator core
    input_remapping_directory = /opt/retropie/configs/nes/
    video_shader = /opt/retropie/emulators/retroarch/shader/phosphor.glslp
    video_shader_enable = true
    video_smooth = false
    input_remap_binds_enable = true
    input_player1_b = "2"
    input_player1_a = "0"
    input_player2_b = "2"
    input_player2_a = "0"
    

    I’m using RetroPie v3 on an RPi1 B+, standard configuration for RetroArch and ES (experimental Kodi installation in case that makes any difference at all). I’ve trawled every resource I can get hold of and just cannot get this one small issue fixed.

    Is something telling RetroArch to reset the remap commands? Am I passing commands through in the wrong format? Any advice would be greatly appreciated.

    #98420
    Profile photo of Floob
    Floob
    Moderator

    In short, try putting your overrides at the very top of the file at
    /opt/retropie/configs/{systemname}/retroarch.cfg
    (Dont edit the one in /all/)

    In long, watch this video:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98429
    Profile photo of link2803
    link2803
    Participant

    Thanks, that seems to do the trick. It’s not the most elegant way of remapping but I’ll only have to do it once for each system I use.

    #98433
    Profile photo of Floob
    Floob
    Moderator

    If you want the remapping to be the same for all systems, you could just edit the controller file in
    /opt/retropie/emulators/retroarch/configs/

    The one you use is shown when you start a game – the name will appear in yellow text at the bottom of the screen.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar