Uae4pi, fails build

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by  Vgrazz 2 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #73084
    Profile photo of ernisius
    ernisius
    Participant

    Hi,

    With a new raspbian image, I did apt-get update and install, and attempted the source based install of retropie.

    most of it works fine but i can’t get uae4pi to build.

    I get this error.

    /usr/bin/ld: src/m68k/uae/fpp.o: undefined reference to symbol ‘tan@@GLIBC_2.4’
    //lib/arm-linux-gnueabihf/libm.so.6: error adding symbols: DSO missing from command line
    collect2: error: ld returned 1 exit status
    make: *** [uae4all] Error 1

    I tried again with the package installer and got the same message,

    Can anyone help with a pointer to what I am missing.

    Thanks

    #77517
    Profile photo of ernisius
    ernisius
    Participant

    Tried again with the latest raspbian and the latest retropie source based install and get the same problem.

    Am I the only one with this problem?

    #77821
    Profile photo of shadow128
    shadow128
    Participant

    No, you’re not alone 😉

    I’ve the same problem with compiling some emulators.

    #78252

    Vgrazz

    Hi,

    I have the same problem with a fresh 2.4 image, apt-get update ..and amiga emulator..

    other emulators compile just fine..

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar