Two SNES USB Controllers

Home Forums RetroPie Project Controller Configuration in RetroPie Two SNES USB Controllers

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #96075
    Profile photo of wiskid
    wiskid
    Participant

    I have two SNES USB Controllers running on an R-Pi 2 with version 2.6 RetroPie. Both controllers function as they should (using this config — http://blog.petrockblock.com/wp-content/uploads/2015/01/retroarch.cfg_.txt). However, in Super Mario World, the P1 controller functions fine. When it comes for P2 to play, the controller doesn’t gain function until it’s in a map. That is, the P1 controller has to be used to navigate P2 (Luigi) to the map that you want to play. Once I click A (on P1 controller) to enter the map, the P2 controller gains control, and it works flawlessly until it’s P1’s turn again. I know it may not make a whole lot of sense. If it’s not understandable, I can take a video of it after work.

    This is a separate issue, but on Super Mario Bros 3, on NES, P1 and P2 are reversed. Is this a config issue?

    I saw a post on here suggesting to use a different emu — is that the only work around? Does the BETA 2 work better?

    Thanks,
    Shane

    #96079
    Profile photo of herbfargus
    herbfargus
    Moderator

    It probably wouldn’t hurt to try another emulator and see if that changes anything. That way it will narrow down if it is really an emulator issue or a controller issue.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar