terminate called after throwing an instance of 'std::bad_alloc'

Home Forums RetroPie Project Everything else related to the RetroPie Project terminate called after throwing an instance of 'std::bad_alloc'

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of InsecureSpike InsecureSpike 2 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #96371
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    To begin with I’ve already posted this over at retropie’s GitHub

    this has just started happening? while scrolling though lists of games, i’ve added 1 of my previous gamelists.xml for gameboy and gameboy roms

    terminate called after throwing an instance of 'std::bad_alloc'
    what(): std::bad_alloc
    /use/bin/emulationstation: line 20: 2540 Aborted $es_bin "$@"
    Emulationstation will restart in 5 seconds. Press a key to exit back to console.

    i’m on a rp2, and this happens now with both betas, with clean builds
    very unsure whats happening as everything was running perfect! also the other odd thing is press f4 or quit via controls and it takes you out but the “any button press to console” don’t work?

    ok this has something to do with gamelist.xml’s i think as my snes gamlist.xml works perfect but the gb one returns that issue above, i’ve verified the xml contains no errors via an online checker really not sure what to do next,

    #96377
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok, think i’ve figured it out!

    ill get back once tested…

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar