Strange SNES issue with snes9x

Home Forums RetroPie Project Everything else related to the RetroPie Project Strange SNES issue with snes9x

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of chickens chickens 2 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #92438
    Profile photo of chickens
    chickens
    Participant

    I’ve been trying to configure two controllers to work correctly within snes9x for the better part of the afternoon.
    What’s happening is 1P’s controls are all sorts of wonky, Select closes the emulator, A resets the game…
    2P is better, but still isn’t totally functional.

    I’m using two of the “Classic USB Super Nintendo Controllers” you get off Amazon and such. G-Tron brand, and all grey/purple.

    I’ve run the controller config through RetroPie-Setup, and tried to map it through snes9x as well.

    Two player works flawlessly on NES, and my controller works well on GBA/GameGear emulations.

    What am I missing?

    #92452
    Profile photo of taalas
    taalas
    Participant

    To me it sounds as if you have mapped the modifier button incorrectly. You can define a button (select for example) that when pressed in conjunction with another button will execute emulator functions like exit, reset, savestate handling etc.

    What version of SNES9x are you using, the standalone or the libretro core? If you are not sure: Do you use RetroPie from the SD card image and have you updated anything at all?

    #92605
    Profile photo of chickens
    chickens
    Participant

    To me it sounds as if you have mapped the modifier button incorrectly.

    To my knowledge I haven’t. I went through the controller setup and input the buttons as prompted, and left the buttons I didn’t have (L3, R3, etc.) empty.

    I’m running snes9x V1.39 from RetroPie on the SD card.
    I’ve updated quite a bit of things, but I don’t remember everything specifically.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar