Strange button mapping problem

Home Forums RetroPie Project Everything else related to the RetroPie Project Strange button mapping problem

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6935
    Profile photo of okapi
    okapi
    Participant

    I might have missed something obvious, but I can’t get past the installation. When RetroPie boots up for the first time I’m asked to map the buttons for the first controller, or press F4 to skip. Well, when I press F4, it maps it to ‘up’! I’m honestly stumped. Tried reinstalling a few times, but the problem persists; skipping the button mapping bit is impossible. What am I doing wrong?

    #6936
    Profile photo of
    Anonymous

    If it is the first initial install, you can not skip this. You must have a way of input to control the GUI. If you want, map it to wasd and so on. Then, if you want a controller, they provide input configuration as an option.

    #6940
    Profile photo of okapi
    okapi
    Participant

    Thank you. After fiddling with it for a while I tried another keyboard, and didn’t encounter the problem. No idea what caused it, but at least now I know what to avoid.

    #6945
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    If you want to map the controls to a gamepad you can reset the input config with:

    rm /home/pi/.emulationstation/es_input.cfg

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar