Sound issues if emulator is started from command line

Home Forums RetroPie Project Everything else related to the RetroPie Project Sound issues if emulator is started from command line

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of meneerjansen meneerjansen 1 year, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #109778
    Profile photo of meneerjansen
    meneerjansen
    Participant

    I’m trying to get a Colecovision emulator running. I’ve got two binaries now that work. However, I noticed that they do not have sound.

    Then I tried to start another emulator (mame4all), that definitely works w/ sound from within EmulationStation (ES), from the command line instead of via ES. No sound either!

    Some of you might know that ES starts emulators via “a script” (see /etc/emulationstation/es_systems.cfg) with a command like this:
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ mame-mame4all %ROM%</command>

    I cannot get ES tot start the Colecovision emu with such a commend via the “runcommand”, I just run it from ES like this in /etc/emulationstation/es_systems.cfg:
    <command>/opt/retropie/emulators/coolcv/coolcv_pi %ROM% </command>
    But that results in the emu running without sound.

    Why don’t I get sound in emulators when I start them from the command line?

    • This topic was modified 1 year, 5 months ago by Profile photo of meneerjansen meneerjansen.
    • This topic was modified 1 year, 5 months ago by Profile photo of meneerjansen meneerjansen.

    #109783
    Profile photo of meneerjansen
    meneerjansen
    Participant

    Stop the press! I’ve been using Linux for ten years now and had many a problem. When I got the solution I always understood why the solution worked. This time, however, I don’t get why the following works:

    1. Goto the Retropie config screen in EmulationStation
    2. Choose ‘configure audio’
    3. In the dialog script/screen choose ‘Auto’ (as opposed to HDMI or headphones etc.).
    4. Sound works.

    Maybe one day I’ll find where this shell script is on the SD card and then I’ll kmow why it works and Alsa settings don’t… 🙂

    [edit] Oops. Sound works via command line except in ‘colem’ (the Colecovision emu that runs games at the right speed).

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar