[SOLVED] 2 PS3 CONTROLLERS

Home Forums RetroPie Project Controller Configuration in RetroPie [SOLVED] 2 PS3 CONTROLLERS

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of bengus bengus 1 year, 6 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #105872
    Profile photo of asipsis
    asipsis
    Participant

    Hi guys. I had watched floobs video on how to pair ps3 on retropie 3 and it worked. But only for 1 controller. Here is how I got 2 to work for me.

    I’m on retropie 3.0
    Installed from SD card
    Using “pluggable” bluetooth dongle brand
    Using 1 playstation controller with no rumble pack and one with dual shock

    So.

    So here is how it worked for me.

    1.Sync the first one just like Floobs Video
    2.Configure controller with retroarch
    2.2 Configure controller with emulation station as well
    3 SOLUTION – Above the exit 0 in the /etc/rc.local add: “hciconfig hci0 piscan” with no quotes
    3.1 Edit – Add a 15 second delay before emulationstation. I actually forget where the file is but it might be etc/emulationstation.cfg or/.cfg
    4. Turn off pi.
    5. When you turn on pi watch for the bluetooth dongle to light up. As soon as it does. Hit ONE! playstation sync button. It will take a while to sync. All the way to emulationstation completion. AFTER THE FIRST ONE SYNCS HIT SYNC ON THE SECOND! ALWAYS SYNC THE SAME CONTROLLERS IN THE SAME ORDER ON BOOT. IT SEEMS TO WORK BETTER.

    6. If this did not work for you. The only part of my setup that I cannot remember is if I had to plug in the second controller and do step 1 with floobs video. So worst comes to worst do the whole floob video with second controller and you should be good to go.

    7. This does not work for me if I have a wifi dongle attached at same time. Strange. But if I remove it – works flawlessly so far

    Hope this helped someone out! Floob please make a video showing how to do 2nd controller? You the man!

    • This topic was modified 1 year, 7 months ago by Profile photo of asipsis asipsis.
    • This topic was modified 1 year, 7 months ago by Profile photo of asipsis asipsis.

    #106294
    Profile photo of quackwalks
    quackwalks
    Participant

    Retro Pie 3.0
    Rpi 2
    2 official ps3 controllers
    1 pluggable brand usb dongle

    I can confirm this worked for me, but only if I used a video splash screen which took 30 seconds to complete. (the legend of retro splash screen) I tried using an image splash screen only once but I think they need some time to connect.

    • This reply was modified 1 year, 7 months ago by Profile photo of quackwalks quackwalks.
    #106298
    Profile photo of quackwalks
    quackwalks
    Participant

    It did work, until I updated an emulator and tried to play some neo geo games. It seemed like a fluke.

    I tried a back up and changed the line of code. I would have to remove the ps3 controller setup and re install it. Then after pairing the controllers and doing a full shut down, they would both pair again, but they would only do it once. I’m getting an error durring boot that says,
    Can’t set scan mode on hci0: Network is down (100)
    [FAIL] startpar: service(s) returned failure: rc.local … failed!

    I assume this relates to the change suggested in this solution.
    I’ll start from scratch in a year or so.

    • This reply was modified 1 year, 7 months ago by Profile photo of quackwalks quackwalks.
    • This reply was modified 1 year, 7 months ago by Profile photo of quackwalks quackwalks.
    #106626
    Profile photo of asipsis
    asipsis
    Participant

    lol.

    #106654
    Profile photo of majerle9
    majerle9
    Participant

    asipsis,
    Have you been able to get multiple controllers to pair on 100% of startups? I followed your ‘hciconfig hci0 piscan’ method and I’m only getting it to work about 70% of the time. When it works the dongle will turn on and start pairing when the splashscreen displays. The other times my bluetooth dongle fails to turn on so I can’t pair my controllers. I get the same error as quackwalks

    Can’t set scan mode on hci0: Network is down (100)
    [FAIL] startpar: service(s) returned failure: rc.local … failed!

    I can’t figure out why bluetooth works sometimes but not every time. Is it possible that the splashscreen finishes too quickly before the dongle can turn on? Is there a way to extend the boot period when the splashscreen is running to give the dongle enough time to turn on?

    Or am I wrong and the answer is something else entirely?

    #106681
    Profile photo of asipsis
    asipsis
    Participant

    Hi guys. I made a quick edit.

    Look at 3.1 above and also look at caps locks in comments. You have to actually sync 1 at a time and always in the same order for best results.

    You might have to attach usb cable first times if you’ve lost sync so it can recatch then reboot and always sync in same order. Let me know if you get different results.

    And sorry no idea about error messages you are getting as I am not getting those.

    Cheers.

    • This reply was modified 1 year, 7 months ago by Profile photo of asipsis asipsis.
    #106888
    Profile photo of majerle9
    majerle9
    Participant

    Thank you asipsis for mentioning the 15 second delay. I just made two changes and now it seems like everything is working. Here’s what I did in case anyone else is facing the Can’t set scan mode on hci0: Network is down (100) error.

    Step 1: Add a 15 second sleep command before EmulationStation starts.

    cd /usr/bin/
    sudo nano emulationstation

    After the #!/bin/bash line, before the $es_bin, add the command sleep 15.
    My script now looks like:

    #!/bin/bash
    
    sleep 15
    es_bin="/opt/retropie/supplementary/EmulationStation/emulationstation"
    
    nb_lock_files=$(find /tmp -name ".X?-lock" | wc -l)
    if [ $nb_lock_files -ne 0 ]; then


    Step 2: Change rc.local

    cd /etc
    sudo nano rc.local

    Add the following 2 lines right before the “exit 0″ line:

    hciconfig device up
    hciconfig enable pscan
    • This reply was modified 1 year, 7 months ago by Profile photo of majerle9 majerle9.
    #106954
    Profile photo of quackwalks
    quackwalks
    Participant

    Works for me. Thank you so much.

    #108174
    Profile photo of bengus
    bengus
    Participant

    majerle9, thank you so much for this. I just recently updated my rp2 to retropie 3.1 (from 3.0 beta and have used other builds prior), because I ended up getting a larger (128 gig) micro sd. Prior to this version, I never had any issues with my dualshock 3 pairing properly at startup, or re-pairing after turning it of manually (holding the ps button for 10 seconds). As soon as I upgraded the build to 3.1 (from scratch, fresh image etc….) I could only get the dualshock to pair wireless properly after the initial setup. After that, if I shut down or re-started the pi2 it was random at best, and if I turned it off manually it would *never* re-pair.

    adding these two lines to /etc/rc.local (above zero)fixed everything perfectly!

    hciconfig device up
    hciconfig enable pscan

    I wish I understood what these two commands actually technically told the rc.local file to do, but it fixed all my issues. If anyone wants to enlighten me, I would appreciate it 🙂

    I have also noticed as of this build (to me at least, and with my controller and setup), adding a delay “sleep” timer to the emulationstation script is no longer necessary after your game pad has been configured with emulation station at least once. After this, if you are in emulationstation well before the dualshock 3 is paired, and it has already been configured, all you have to do is hold down one button on the gamepad and it will go right into emulationstation without asking you to reconfigure it like previous versions. Has anyone else noticed or tried this? It should be documented because its a pretty fantastic new feature of the Retropie build (if it already has been mentioned, I apologize). Anyways, thank you again….and to Floob/Herbfargus and everyone who ever worked/works so hard on this project, and has helped me (via forum or videos) 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar