SNES emulator issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: ,

This topic contains 17 replies, has 4 voices, and was last updated by Profile photo of mw99 mw99 1 year, 3 months ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #114067
    Profile photo of mw99
    mw99
    Participant

    The other day I installed the 3.3 Jessie (BETA) version of RetroPie on my Raspberry Pi model B. It worked fairly well, I had some issues with WiFi and my controller, but was able to play a few games. I tried “Super Mario World – SNES” and it worked quite well.

    Today I decided to try the stable 3.3.1 Wheezy version, so I installed it and my WiFi/controller issues were gone. Everything is working pretty well so far, except for the SNES emulator. Now, Super Mario World is blurrier, laggier, and the audio is horrible. I did some searching around and a lot of people said to switch to PiSNES. I changed the default SNES emulator from “lr-pocketsnes” to PiSNES, and the performance was much, much better and the audio was good too. However, the controls do not match what I configured via EmulationStation (I’m using a XBox 360 controller), the hotkeys (EX: Start+Select to exit the rom) don’t work, and I’m not even able to exit the game by pressing the Esc key. The only way to exit the game is by either unplugging the Pi or pressing Ctrl+Alt+Del. I switched back to lr-pocketsnes, but the overall lag is very frustrating.

    If I could get some help that would be great!

    #114134
    Profile photo of mw99
    mw99
    Participant

    Anyone?

    I’ve tried enabling the Modest overclock, changing audio drivers, lowering audio output freq, enabling v-sync, and switching to lr-armsnes.

    The video and speed were a bit better after switching to lr-armsnes, overclocking, and enabling v-sync. The audio is still pretty terrible.

    Is there anything else I can do to speed it up other than increasing my overclock settings? Or is the Pi B simply not powerful enough to run some of these SNES games?

    #114136
    Profile photo of jeffdamann
    jeffdamann
    Participant

    Use lr-snes9x-next and your problems will be gone.

    #114139
    Profile photo of mw99
    mw99
    Participant

    Use lr-snes9x-next and your problems will be gone.

    Apparently the RPi 1 doesn’t support that.

    #114148
    Profile photo of mw99
    mw99
    Participant

    Is there anything else I can do? Most other emulators besides the N64 work fairly well, it’s just the SNES…

    #114203
    Profile photo of mw99
    mw99
    Participant

    Anyone at all?

    #114206
    Profile photo of herbfargus
    herbfargus
    Moderator

    Get a raspi 2? The hardware can only go so far.

    #114207
    Profile photo of buzz
    buzz
    Keymaster

    I have used the SNES fine on my Raspberry Pi B – do you have a sufficient PSU ? Overclocking ? Which games in particular – are some ok and some not ?

    If you give me a specific example I can check on my set up.

    #114208
    Profile photo of buzz
    buzz
    Keymaster

    There were some changes around in the pocketsnes emulator that means some optimisations may have been switched off by default. I will check that. I believe I had to change some stuff due to it not building correctly.

    #114232
    Profile photo of mw99
    mw99
    Participant

    I have used the SNES fine on my Raspberry Pi B – do you have a sufficient PSU ? Overclocking ? Which games in particular – are some ok and some not ?

    If you give me a specific example I can check on my set up.

    I was using a 5v 1A power supply, I switched to a 2A one but didn’t notice much difference.
    I have it set on the “Modest” overclock setting.

    Super Mario World runs decently on some levels with lr-armsnes, (they were all horrible with lr-pocketsnes) but on some levels like the castle and Ghost House, things get a bit laggy.
    I also tried Yoshi’s Island, but it lags and the audio is terrible right when the opening video pops up.

    I’m using a SanDisk 16GB class 4 card, so I don’t think that’s an issue. I’ve tried changing a ton of settings, re-flashing the image, etc.

    I realize the Pi B is outdated, but I’ve seen several YouTube videos of people playing without an issue.

    • This reply was modified 1 year, 3 months ago by Profile photo of mw99 mw99.
    #114327
    Profile photo of buzz
    buzz
    Keymaster

    I have rolled back our pocketsnes code to how it was before.

    Please update RetroPie-Setup script, and the reinstall lr-pocketsnes (via menu 5 – install individual emulators from binary or source) and let me know if it works better for you.

    #114334
    Profile photo of mw99
    mw99
    Participant

    I have rolled back our pocketsnes code to how it was before.

    Please update RetroPie-Setup script, and the reinstall lr-pocketsnes (via menu 5 – install individual emulators from binary or source) and let me know if it works better for you.

    Games don’t launch at all now.

    #114335
    Profile photo of buzz
    buzz
    Keymaster

    sorry, please update retropie-setup again and re-install it from binary.

    #114336
    Profile photo of mw99
    mw99
    Participant

    sorry, please update retropie-setup again and re-install it from binary.

    The game performance is definitely better. It’s still a bit laggy in a few parts of Super Mario World (like the Ghost House). The audio is still pretty crackly and fuzzy though. I’m using a pair of speakers through the 3.5mm jack rather than HDMI if that makes a difference. It’s not my speakers, as they sound just fine with my music player.

    #114338
    Profile photo of buzz
    buzz
    Keymaster

    Yeh after some further testing – there is little difference really – and the previous code has audio interpolation which sounds better (slightly slower, but not much).

    I am going to revert back to the upstream code, but overclock your rpi more and it should be better. also you can try configuring “runcommand” from the retropie-setup setup / configuration menu and set governor to performance which might help too). If it’s fine on ondemand though leave it like that.

    can also try the dispmanx video output driver. go to retropie-setup / setup / configuration menu and go to config editor. edit common options / all/retroarch.cfg and set video_driver to “dispmanx”

    to improve rpi audio via jack, and remove background hiss you can try adding disable_audio_dither=1 to /boot/config.txt

    overclocking more is the best bet though imho.

    #114341
    Profile photo of mw99
    mw99
    Participant

    Yeh after some further testing – there is little difference really – and the previous code has audio interpolation which sounds better (slightly slower, but not much).

    I am going to revert back to the upstream code, but overclock your rpi more and it should be better. also you can try configuring “runcommand” from the retropie-setup setup / configuration menu and set governor to performance which might help too). If it’s fine on ondemand though leave it like that.

    can also try the dispmanx video output driver. go to retropie-setup / setup / configuration menu and go to config editor. edit common options / all/retroarch.cfg and set video_driver to “dispmanx”

    to improve rpi audio via jack, and remove background hiss you can try adding disable_audio_dither=1 to /boot/config.txt

    overclocking more is the best bet though imho.

    Thanks for the help. I’ll try your suggestions and let you know how it goes.

    I don’t want to increase my overclock because all the ones above “Modest” include overvolting, which I am not comfortable with doing to my Pi.

    (Is there a way for me to save this older version of lr-pocketsnes in case I ever have to re-flash my card?)

    #114342
    Profile photo of buzz
    buzz
    Keymaster

    I’ve had 2 rpi1 in cases without ventilation with no heatsinks overclocked at 1ghz for 2+ years. system throttles if it gets too warm.

    you can save it by backing up /opt/retropie/libretrocores/lr-pocketsnes – but you will need to adjust the configs/snes/emulators.cfg to point to it. There is no point though imho. The sound is worse, and the performance difference not noticable on my rpi1.

    • This reply was modified 1 year, 3 months ago by Profile photo of buzz buzz.
    #114604
    Profile photo of mw99
    mw99
    Participant

    Set the overclock to Turbo and most of my issues are gone. :3

Viewing 18 posts - 1 through 18 (of 18 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar