SMS emulation with Genesis Plus GX *without* FM audio

Home Forums RetroPie Project Everything else related to the RetroPie Project SMS emulation with Genesis Plus GX *without* FM audio

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of eightbit eightbit 2 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #94490
    Profile photo of eightbit
    eightbit
    Participant

    I have been reliving various aspects of my gaming history through Retropie lately (thanks everyone involved in this wonderful project!) and have run into a few stumbles when it comes to Sega Master System emulation. Initially I was quite surprised to see the over 10 year old “Astro Warrior bug” present in Picodrive. I reported this bug to the emulation authors at the time and thought it was crushed/gone. It is a bug where shooting the bases really did not destroy them..just made them shootable glitchy artifacts. It ruins the game as you cannot shoot through them (you are supposed to be able to when they are destroyed) and powerups are counted by the amount of these you destroy. Apparently the author of Picodrive is using some REALLY old code 🙂

    Luckily Genesis Plus GX has the corrected code and it works great, but I cannot seem to find a way to turn off the FM audio. For those unaware, the Japanese console had an FM audio enhanced chip that made the sound “better” on some games. In the USA, we did not have that chip. So the games with the FM enabled sound “weird” to us. In the retroarch core options the option to turn it off exists, but if I do and then reset the game I get nothing.

    I cannot find a documented switch that I can add to the config to turn it off, and I scoured the net only to find three people asking the same question in the Libretro forums with no answer.

    I figured I’d try my luck here. Maybe someone who is into the SMS as much as I am is aware of this and can assist. I have a feeling it is a simple switch to the config. Any help is appreciated.

    #94626
    Profile photo of eightbit
    eightbit
    Participant

    So I had an idea that I would change the Master System FM from it’s default “auto” to “disabled” in the core options, save the configuration and then inspect it and see if I could find the switch. But no, I do not see it. Are all options for the cores stored in the retroarch.cfg or anywhere else?

    EDIT: Looking more deeply, it appears the option should reside in the retroarch-core-options.cfg. More specifically:

    ym2413 = “disabled”

    That *should* have solved the issue, but FM audio is still on, still set to “auto” in Genesis Plus GX core options. It doesn’t make sense. I feel I am so close 🙁

    • This reply was modified 2 years ago by Profile photo of eightbit eightbit.
Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar