Simple but complicated issues

Home Forums RetroPie Project New to RetroPie? Start Here! Simple but complicated issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 7 voices, and was last updated by Profile photo of bic12345 bic12345 1 year, 7 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #103268
    Profile photo of bic12345
    bic12345
    Participant

    Hello everybody!

    I’m having some problems with the configurations of my retropie, and i want some help of you guys. If you can help me of course…

    Before i start i would like to apologize for my bad english. I’m Brazilian, and maybe i have some problem to say exactly what i need, if so, please ask me and i will try to put it into another way.

    So here we go!

    I just config my retropie (raspberry pi2 with retropie 3.0 BETA 4) to load games directly from the usb, everything ok until now, but i’m having problems to save state. Every time that i try to save, or load, it fails! Does anybody here have any idea of how to fix it?

    and…

    I’m having some vídeo problems with n64 and psx as well, both emulators have a high tax of lag (n64 is almost frozen), what can i do to improve the performance?

    In any case, thank you for your time! Hope you can help me =)

    #103277
    Profile photo of jenksie
    jenksie
    Participant

    Which games lag on N64? A lot of N63 games still lag so it could be the game.

    #103286
    Profile photo of adcooney
    adcooney
    Participant

    I believe the save state is due to permissions on the folder. I think the RetroPie Setup script has a helper menu to solve it or you can run chmod on the RetroPie/roms directory.

    Something like (but probably not as this is rwx for all):
    sudo chmod -R 777 ~/RetroPie/roms

    As for the N64 the emulator (mupen64plus) has several ‘plugins’ that are used for the video player; different games require not only different plugins but also occasionally different configuration as well.

    There is a thread in the general section for N64 compatibility list. Please check there.

    #103442
    Profile photo of bic12345
    bic12345
    Participant

    First of all, thanks for your messages and sorry for this delayed answer.

    I tried chmod method but it failed, i still can’t save my games =(

    There is anything that i can edit with ‘sudo nano’ to change the saving directory? I can, for example, create a folder at my pendrive and change the patch of save to this folder?

    #103517
    Profile photo of funigui
    funigui
    Participant

    I would say ssh into the pi and read the permissions. You may also have changed the permission on the main roms folder, but not all the folders within.

    Sent from my SM-N900T using Tapatalk

    #103565
    Profile photo of bic12345
    bic12345
    Participant

    Sorry Funigui, i don’t understand exactly what you said. Better, i don’t know how to perform this ssh.

    #103566
    Profile photo of herbfargus
    herbfargus
    Moderator

    for ssh see this page of the wiki:

    https://github.com/RetroPie/RetroPie-Setup/wiki/How-to-get-ROMs-on-the-SD-card

    You can use something like winscp to ftp into the raspberry pi and you can view permissions that way or you can type ls -lah in the terminal to get more details on the files in the directory you’re in.

    #105245
    Profile photo of bic12345
    bic12345
    Participant

    Hi everybody! I’m back =)

    I still can’t save my games, but now i maybe know whats happening!

    I tried to change the permission of ‘/media/usb’, i used the command chmod -R 777 /media and it kind of work, only the usb0 folder didn’t change.

    For your understand i load my games directly from the usb and i changed the patch of my saved files to ‘/media/usb/save’, at least i tried to hahaha

    I changed retroarch config file at the ‘/opt/retropie/all’ folder, or something like that…

    What else i have to do!? Thanks for your concern and, if you don’t understand my english, ask me to repeat and sorry hahaha

    #105294
    Profile photo of dankcushions
    dankcushions
    Participant

    i’m not sure about changing save directory, but for your USB drive – is it FAT32? if it is, you’ll have to set the permissions when you mount it.

    for me, i mount the drive automatically every time i boot using fstab, and i give it 777 permissions for all users. i can’t remember exactly how i did this, but there’s some help on the net: http://askubuntu.com/questions/251206/mount-usb-drive-with-write-permissions-for-everyone-or-specific-user

    #105393
    Profile photo of bic12345
    bic12345
    Participant

    I will take a look, thanks =)

    #106416
    Profile photo of bic12345
    bic12345
    Participant

    I changed my fstab config, but not happens =(
    So i take some pictures of my setup. if you see a mistake, please tell me =)

    fstab
    Media Permission
    Retroarch config

    #106420
    Profile photo of buzz
    buzz
    Keymaster

    http://serverfault.com/a/43636

    Add the uid/gid of the pi user. (Probably uid=1000,gid=1000)

    #106561
    Profile photo of bic12345
    bic12345
    Participant

    It worked!!!! Thanks everybody, i’m very, very happy! And yes, the UID and the GID are 1000.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar