Shaders make the emulation very slow [Retropie v3.00 Final RPi2]

Home Forums RetroPie Project Everything else related to the RetroPie Project Shaders make the emulation very slow [Retropie v3.00 Final RPi2]

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of buzz buzz 1 year, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #105836
    Profile photo of kommissar
    kommissar
    Participant

    Hi,

    I got a problem when i use shaders with retroarch on lot of cores (i didn’t test all, just SMS, MD, PCE, FBA, GG, SNES).
    In the RC 1 or 2 (i don’t remember), when i launched a game with the selected option : “Select RetroArch render res for lr-xxxx” with “output”, i could change shaders ingame and most of them worked perfectly (i usually used “phosphor”) and the game ran full speed (no sound issues too).
    In the Final, if i launch a game with these settings :
    * Select RetroArch render res for lr-xxxx 640×480, shaders works but are ugly (phosphor is the best example, really ugly), the game runs fine.
    * Select RetroArch render res for lr-xxxx output, shaders works (i mean not ugly) BUT the game is unplayable (extremely slow + sound totally broken).

    For info, i tried that on several different class10 sd cards from the latest Retropie v.3.00 Final img. Of course i overclocked the Pi. I tried before and after updating retroarch : same result (retropie-setup/5 update emulators/retroarc…)

    Does anyone experience the same problem ?

    Unfortunately, i didnt keep the RC1-2 image of Retropie to test what is different between the 2 versions.

    EDIT :
    Solution : (thx to buzz)
    Go in emulationstation > Retropie > Retropie-setup
    Then choose option 3 : Setup/Configuration (to be used post install)
    Then choose option 304 : Edit RetroPie/RetroArch configurations
    Then choose option 1 : Change common RetroArch options
    Then choose option 0 : all/retroarch.cfg
    Then choose option 2 : video_threaded
    Put it to true.

    Tada !!!

    • This topic was modified 1 year, 7 months ago by Profile photo of kommissar kommissar.
    • This topic was modified 1 year, 7 months ago by Profile photo of kommissar kommissar.
    • This topic was modified 1 year, 7 months ago by Profile photo of kommissar kommissar.
    • This topic was modified 1 year, 7 months ago by Profile photo of kommissar kommissar.
    • This topic was modified 1 year, 7 months ago by Profile photo of kommissar kommissar.

    #105839
    Profile photo of buzz
    buzz
    Keymaster

    did you turn off video smoothing and did you try turning on threaded_video ?

    you can do this from retropie-setup -> supplementary menu -> Edit RetroPie/RetroArch configurations -> Change common RetroArch options – then choose all/retroarch.cfg

    ?

    #105879
    Profile photo of kommissar
    kommissar
    Participant

    Oh man !!!!! Thanks a lot !!!!
    I had already turned off the smooth options in the all/retroarch.cfg.
    But i didn’t change the threaded_video option !!!

    threaded_video is now “on” and it works perfectly (like before !!!).
    I missed that change between the different retropie versions.

    Thx again 😀

    • This reply was modified 1 year, 7 months ago by Profile photo of kommissar kommissar.
    #105889
    Profile photo of buzz
    buzz
    Keymaster

    I may consider changing the default again – when I initially tested, I didn’t notice major slowdown, but then I didn’t test full screen shaders etc. The reason it is changed is according to the retroarch documentation, perfect sync is not possible with threaded video, and as I didn’t initially notice any performance decrease on the pi2, it got switched.

    It’s simple to change of course with the new editor – no need to manually edit files.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar