SFTP Permissions Questions

Home Forums RetroPie Project New to RetroPie? Start Here! SFTP Permissions Questions

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of retronoob retronoob 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #101924
    Profile photo of retronoob
    retronoob
    Participant

    Hey Everyone,
    I have a question, I’m sure many of you will find very simple. I apologize for such a simple question.

    So I wanted to change my splash screen and I was doing it via sftp. When I tried to upload the file to the sftp I got the “Issue 1.jpg” image telling me I didn’t have permissions. When I went to the home folder – or any folder or file – and tried to change the permissions I got the “issue 2.jpg” image telling me I needed to contact my admin/didn’t have permissions. I need to make the permissions global so I can upload the splash screen to the pi via ftp.

    How do I change the permissions for the pi and the various folders and files (Splashscreens, home, etc) via ssh or directly on the Raspberry pi with a keyboard patched in.

    Thanks for the help guys!

    Attachments:
    #101928
    Profile photo of herbfargus
    herbfargus
    Moderator

    The easiest way I’ve found is to just log in as user root rather than user pi. The root password is disabled by default with retropie 3.0 but you can easily re-enable it with sudo passwd root then choose a new password, sign in your ftp as root with the new password you created and you should be able to add and change what you need.

    #101959
    Profile photo of retronoob
    retronoob
    Participant

    AWESOME! That worked, thanks herbfargus!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar