Setting up Sixaxis Failure

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 6 replies, has 6 voices, and was last updated by Profile photo of esbiete esbiete 2 years, 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #87488
    Profile photo of sudodaemon
    sudodaemon
    Participant

    Raspberry Pi B+
    RetroPie 2.5.0

    I’m trying to set up sixaxis so I can use my PS3 controller, following this guide…

    https://github.com/petrockblog/RetroPie … controller

    And this is what happens.

    pi@retropie:/home/pi# gcc -o sixpair sixpair.c -lusb
    cc1: error: /usr/local/include/arm-linux-gnueabihf: Not a directory
    cc1: warning: /usr/local/include: not a directory [enabled by default]
    pi@retropie:/home/pi#

    So, I’ve looked, and they are definitely not directories, seems as though if it pointed to /usr/include/arm-linux-gnueabihf it would be happy, because that is where everything lies…. I’m stuck here… I’ve reinstalled gcc, brain fart…

    #87490
    Profile photo of buzz
    buzz
    Keymaster

    Did you try doing it from the option in the setup menu ? (making sure you have the latest version of the retropie-setup script)

    #87491
    Profile photo of sudodaemon
    sudodaemon
    Participant

    Yup, when installing the drivers it goes through some things on the screen, then just quits out back to the setup screen.

    #88571
    Profile photo of killerajd
    killerajd
    Participant

    ***UPDATE***
    I ended up re-imaging my SD card with RPI v2.6.0 and that seemed to fix my issue.
    ***UPDATE***

    I’m also having the same issue. Running a Pi 2 and installed RPI v2.6.0. If I try to install the PS3 controller driver through the retropie_setup script, it gets to a certain point and then fails. I’ve attached the log it spits out. After it fails, it kicks me back to the retropie-setup screen, and when I back out of that it gives me an error:

    Could not successfully install Install PS3 controller driver
    (/home/pi/RetroPie-Setup/tmp/build/ps3controller/sixpair not found).

    In the log, it shows:

    cc1: error: /usr/local/include/arm-linux-gnueabihf: Not a directory
    cc1: warning: /usr/local/include: not a directory [enabled by default]

    I’m kind of at my wits end here. I can’t find anybody else having this issue. Any issues for others seem to arise after this step. I’ve tried apt-get update and then upgrade as maybe something didn’t install correctly, but it doesn’t help.

    Any help would be appreciated.

    • This reply was modified 2 years, 2 months ago by Profile photo of killerajd killerajd.
    • This reply was modified 2 years, 2 months ago by Profile photo of killerajd killerajd.
    Attachments:
    1. log.txt
    #88947
    Profile photo of flickcorp
    flickcorp
    Participant

    SD card is probably on its way out but try updating the pi then run the utilities

    Raspberry Pi B 512mb
    Generic 64gb SD
    Overclock Turbo

    Raspberry Pi B+ 512mb
    Generic 128gb MicroSD
    Overclock Turbo

    Raspberry Pi2 B 1gb
    Samsung Evo 16gb MicroSD
    Overclock Pi2

    #89269
    Profile photo of PeanutButterBoy
    PeanutButterBoy
    Participant

    Any idea what the issue is here? I’ve got the same issue and I’m prepping to re-image my card, but there’s gotta be some way to fix this without a full re-image….

    http://store.peanutbutterboy.com

    - We grind up the best peanut butter in the galaxy!

    #90512
    Profile photo of esbiete
    esbiete
    Participant

    After dealing with it trying to compile last version of openMSX and getting the same error than you I finally got it!

    AngelScript installs as /usr/local/include as an script file, so when you try to compile any source it fails as /use/local/include/arm-linux-gnueabihf/ (which is supposed to be a directory) is consequently not found.

    As a workaround you can create a symbolic link to /usr/include that contains the files you need. Do the following:

    cd /usr/local
    sudo mv include AngelScript_include
    sudo ln -s /usr/include/ include
    

    Doing a ls -l that should look:

    pi@retropie /usr/local $ ls -l
    total 7596
    -rw-r--r-- 1 root root    60280 mar  3  2013 AngelScript_include
    drwxr-xr-x 2 root staff    4096 mar  7 12:40 bin
    lrwxrwxrwx 1 root staff      13 mar  7 17:10 include -> /usr/include/
    -rw-r--r-- 1 root root  7711042 mar  6 06:37 lib
    pi@retropie /usr/local $ sudo ln -s /usr/include/ include
    

    At least it worked for me.

    What I don’t understand is why Angel Script is created as include there, it’s a terrible failure unless there’s any purpose behind. Would be nice to know.

    Regards,
    EB

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar