Seperate button config for NES

Home Forums RetroPie Project Everything else related to the RetroPie Project Seperate button config for NES

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 2 years, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7179
    Profile photo of cougar281
    cougar281
    Participant

    Is it possible to have a separate config for the Xbox 360 controllers for the NES emulator? Normally, prefer the buttons to be mapped so that X = X, A = A, etc, but for NES, it would be better if A was A and X was B.

    #7189
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Yes, place a seperate retroarch.cfg in RetroPie/configs/NES/
    This will override the default config in configs/all/

    If you have found the solution to your problem please mark the topic as resolved.

    #7197
    Profile photo of cougar281
    cougar281
    Participant

    Yes, place a seperate retroarch.cfg in RetroPie/configs/NES/<br>
    This will override the default config in configs/all/

    Thanks, That worked – But still having a problem I can’t figure out – I wanted a way to be able to exit the emulator using the controller – in the config, there is ‘input_exit_emulator = “escape”‘ option. When escape is pressed on the keyboard, it leaves the NES emulator. There is also a ‘input_exit_emulator_btn =’ line that was originally ‘nul’. I changed that to ‘8’ (the Big button between the ‘back’ and ‘start’ buttons), but it does not work – I changed ‘start’ from 7 to 8 and exit from 8 to 7, and start worked fine on 8, but still no exit on 7 – Any ideas why that’s not working?

    #7200
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    To use the exit emulator button you need to assign a hotkey with:

    input_enable_hotkey_btn =

    If you have found the solution to your problem please mark the topic as resolved.

    #7205
    Profile photo of cougar281
    cougar281
    Participant

    Well, I wasn’t sure what you meant I should add, so I added ‘input_enable_hotkey_btn = “8”‘ in addition to ‘input_exit_emulator_btn = “8”‘ and that works – I assume that’s what you meant…

    #7207
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    The hotkey lets you assign multiple functions to one button, e.g. you could set the hotkey as the start button and exit emulator as the select button so the combination of the two will exit the emulator. There are other functions you can access this way too:

    input_save_state_btn =
    input_load_state_btn =
    input_state_slot_increase_btn =
    input_state_slot_decrease_btn =
    input_menu_toggle_btn = (access Retroarch GUI)

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar