Sega CD Help – Music not always playing

Home Forums RetroPie Project Everything else related to the RetroPie Project Sega CD Help – Music not always playing

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , , , , ,

This topic contains 7 replies, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #93711
    Profile photo of seventhsentinel
    seventhsentinel
    Participant

    I have tried several methods of getting Sonic CD to play, but the best I can get seems to only get regular stage music working (no title screen music, invincibility, speed shoes, level end etc). Can someone explain to me how to get it working properly?

    #93716
    Profile photo of herbfargus
    herbfargus
    Moderator

    generally speaking with sega cd files you need both the bin and the cue file in the rom folder in order for it to work with sound.

    #93718
    Profile photo of seventhsentinel
    seventhsentinel
    Participant

    I have tried that. I used a .bin file for the game and .bin files for the music as well, taken from a dump I found online. Would .wav files work for the music?

    #93720
    Profile photo of herbfargus
    herbfargus
    Moderator

    a cue file is needed to cue the music. try using something like this to build a cue file for your bin files:

    http://www.racketboy.com/downloads/sega-cue-maker.htm

    I’m not sure if wav files work or not. all I know is all of my sega cd games won’t work with sound unless the .cue file is there with the .bin file.

    #93722
    Profile photo of seventhsentinel
    seventhsentinel
    Participant

    The cue file works, it’s a matter of whether or not I can use a different audio format to make it work better. They might just be too big to try to load. I’ll see what I can dig up in the picodrive forums (granted that they exist).

    #93725
    Profile photo of seventhsentinel
    seventhsentinel
    Participant

    I dug up a version of picodrive that said it supported .wav files. I went through a few hoops getting the music converted, but it works now. It now cuts off the first few seconds of audio, but I messed with my .cue file a little, so I guess I’ll put it back to normal ad try again.

    #93935
    Profile photo of seventhsentinel
    seventhsentinel
    Participant

    Finally got around to fixing the .cue file. Everything works peachy keen now.

    #93936
    Profile photo of herbfargus
    herbfargus
    Moderator

    Glad you got it worked out, sorry I wasn’t more help. Would you mind documenting some of your steps for others to show how you got it to work?

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar