ScummVM and DOSBox not working (SDL-Error)

Home Forums RetroPie Project Everything else related to the RetroPie Project ScummVM and DOSBox not working (SDL-Error)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of kjozsa kjozsa 2 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #93345
    Profile photo of b16zjc
    b16zjc
    Participant

    Hey,

    after I finally moved all my roms to an external HDD ScummVM and DOSBox wont start anymore. I set the correct paths (in the es_systems.cfg) but get folowing errors if I try to start either of one:

    For ScummVM

    Press 'x' or 'm' to configure launch options for emulator/port (scummvm)
    Could not initialize SDL: Unable to open a console terminal!
    Could not initialize SDL: Unable to open a console terminal!

    And for DOSBox

    Press 'x' or 'm' to configure launch options for emulator/port (dosbox)
    DOSBox version SVN
    Copyright 2002-2013 DOSBox Team, published under GNU GPL.
    ---
    Exit to error: Can't init SDL Unable to open a console terminal

    Before sending them on the HDD they worked fine, besides I had to install it with:

    sudo apt-get install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev

    Afterwards I tried to start ScummVM from SD Card but get the same error.

    If I run it now, it says that everything is up to date. So I really dont know what to do and will be glad if someone could help. Im using a Raspberry Pi 2 with the latest software.

    Edit: I found a hint via google. Someone said that this error means that the keyboard is not found. But my Keyboard is recognized and working (at least in the console).

    • This topic was modified 2 years ago by Profile photo of b16zjc b16zjc.
    • This topic was modified 2 years ago by Profile photo of b16zjc b16zjc.

    #96152
    Profile photo of kjozsa
    kjozsa
    Participant

    The error rather looks like you’re trying to run scummvm / doxbox over a remote pty (ie. ssh to the box and start scummvm from there). Certainly, the framebuffer driver won’t really work this way with your primary output screen..

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar