SD Card size?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by  theRobisaur 2 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3743
    Profile photo of rpinoob
    rpinoob
    Participant

    I’m using a 16GB sd card (Kingston) but when I use win32diskimager and mount the rpi img, my sd card shrinks to 56mb. Then when I’m doing the updates sometimes it will say something along the lines of “not enough room on device”.

    How do I enable my full 16GB?

    #3744
    Profile photo of rpinoob
    rpinoob
    Participant

    To ensure I mounted it correctly, I reformatted it and started over.

    After formatting, it was correctly at the 16gb again.
    After mounting, back down to 56mb.

    I’m going through the commands now:

    sudo apt-get update = all good
    sudo apt-get upgrade -y git = issues

    it says things like…
    /usr/bin/mandb: can’t write to /var/cache/man/2917: No space left on device
    /usr/bin/mandb: can’t write to /var/cache/man/3025: No space left on device
    /usr/bin/mandb: can’t write to /var/cache/man/3251: No space left on device

    sudo apt-get install -y git dialog = ??
    ” the following packages have been kept back: pypy-upstream

    cd
    git clone --depth=0 git://github.com/petrockblog/RetroPie-Setup.git

    = issues
    “fatal: could not create work tree dir ‘retropie-setup’.: No space left on device”

    How can I continue??

    #3747
    Profile photo of
    Anonymous

    It sounds like you just need to expand the usable space on the SD card. After you mount the image type:

    sudo raspi-config

    From this menu select “expand_rootfs” (I think that’s what it says, working from memory). Then reboot and you should be all set.

    #3811
    Profile photo of roquen
    roquen
    Participant

    ^ what he said

    Turn on the pi

    Let emulation station do its booting

    Go to menu then select exit

    It will shutdown emulation station and take you to the console

    At the console type

    sudo raspi-config

    It will open the config app and you'll select

    Arrow to "expand file system"
    Press TAB to get to yes/no options at the bottom

    Save, reboot, done.

    #20526

    theRobisaur

    I’m having the same issue expanding my file system to 64gb capacity. I’ve done this within the raspi-config, but when it reboots, it’s still at 56mb.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar