Scummvm Black Screen (RetroPie 2.4.2 BETA)

Home Forums RetroPie Project Everything else related to the RetroPie Project Scummvm Black Screen (RetroPie 2.4.2 BETA)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 9 replies, has 3 voices, and was last updated by Profile photo of urky urky 2 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #86207
    Profile photo of herbfargus
    herbfargus
    Moderator

    I installed the SD card image for RetroPie 2.4 and went to play a Scummvm game. It worked the first time, but the second time that I opened it, I could hear the sound but no video was showing up. I have it connected with an HDMI cable to my television (configured at 720p).

    I’ve trolled the forums and saw that it may have something to do with Vanfanel’s build of Scummvm (http://www.raspberrypi.org/forums/viewtopic.php?f=78&t=96258, https://github.com/retropie/RetroPie-Setup/issues/589) I haven’t tested composite with it yet as I don’t have a composite cable but from what I understand it only works with composite video and not HDMI.

    As a result I updated the setup script, reinstalled from binary and that didn’t work so I tried updating from source which also didn’t work (which I’m guessing happened because the source hasn’t been updated)

    Perhaps I’m going about it the wrong way, could anyone enlighten me as to how I can fix it so video will work with HDMI?

    #86216
    Profile photo of buzz
    buzz
    Keymaster

    try switching the screenmode before emulator launch to 640×480.
    you can also enable/disable dispmanx support for the emulator in the supplementary config section of retropie-setup

    #86234
    Profile photo of herbfargus
    herbfargus
    Moderator

    I switched the screen mode to 640×480 and it shows blurry start up text and loads with sound but no video

    I enabled dispmanx and it said : “the program is calling SDL_GetVideoInfo. That shouldn’t happen”

    I’m at a loss

    #86257
    Profile photo of buzz
    buzz
    Keymaster

    No idea as it works here both on composite and hdmi with dispmanx off, but if you wait a bit we will update scummvm with a new version that has native pi display out that should solve your problems.

    If it initially worked then maybe something happened to the config – maybe worth going with a fresh image again ?

    #86287
    Profile photo of herbfargus
    herbfargus
    Moderator

    That’s what I ended up doing, I started with a new image and it works just fine. I must have messed something up with the configs somehow (wish I knew what I broke). Sorry for my inexperience with all of this.

    Thanks for all of the hard work on the project.

    **EDIT

    Updating the RPI kernel is what broke Scummvm

    #86296
    Profile photo of buzz
    buzz
    Keymaster

    glad you got it sorted.

    #87708
    Profile photo of urky
    urky
    Participant

    Hi. Seems like i have the same problem as herbargus. (not sure if i should post a new topic since its marked as resolved)
    Im running on 2.4.2 image. and everything worked fine before.
    Now i got as above mentioned only sound and black screen on both scumm and dosbox. have tryed mode change and enabling dispmanx to no use. (in dosbox it kinda worked but everything seems more “choppy” somehow) scummvm only gave me the same error message herb got. also tried reinstalling through source in retropie setup.

    is there a way round this aside of reinstalling the image? iv put a lot of effort in the current one, id hate to start at scratch.

    On another note. Thanks for all the work you guys have put in.
    And the community seems very friendly 🙂

    • This reply was modified 2 years, 2 months ago by Profile photo of urky urky.
    • This reply was modified 2 years, 2 months ago by Profile photo of urky urky.
    #87715
    Profile photo of buzz
    buzz
    Keymaster

    update the script and re-run retropie-setup install (from binaries – option 1)

    • This reply was modified 2 years, 2 months ago by Profile photo of buzz buzz.
    #87718
    Profile photo of buzz
    buzz
    Keymaster

    This was a bug in SDL and the newer kernel. we use a fixed SDL library in retropie-setup now. you should not have any more black screen problems.

    #87721
    Profile photo of urky
    urky
    Participant

    awesome – Thanks alot 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar