Save/load state gpio

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of sublim3 sublim3 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #102080
    Profile photo of cyberpete
    cyberpete
    Participant

    How to use hotkeys for save state and load state when using the GPIO pins. Since i have connected my keys on my gameboy to the gpio pins i cannot follow the normal steps as when using a snes contoller because retropie sees my controller as a keyboard.

    I have all the keys working in the games but dont know how to config so i can save and load.

    ALso i cannot use select and start in emulationstation menus. They work fine in games.

    Anyone that can poine me in the right direction?

    • This topic was modified 1 year, 9 months ago by Profile photo of cyberpete cyberpete.

    #102301
    Profile photo of sublim3
    sublim3
    Participant

    I am trying to do the same thing. I have built an arcade style controller with a joystick and buttons mapped to the GPIO pins. They act as keyboard keys and work great while playing roms. I just havent figured out how to map hotkeys with the keyboard. Hopefully someone else has done it and can help.

    #102319
    Profile photo of sublim3
    sublim3
    Participant

    I was able to get Hotkeys working with my GPIO Controls acting as keyboard.

    cd /opt/retropie/configs/all $ sudo nano retroarch.cfg

    input_player1_l = “l”
    input_player1_r = “r”
    input_hold_fast_forward = “nul”
    input_rewind = “nul”

    input_enable_hotkey = “v”

    input_load_state = “l”
    input_save_state = “r”

    I added the above code. By default the l and r were used for FastForward and Rewind. So making them nul and adding the hotkey command to v which is what one of my buttons maps to enabled that. The only thing that it affected that I wasn’t expecting was the button I had mapped as Esc no longer worked without the Hotkey being used. Other than that, works like a boss! Hope it helps.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar