Save & Load not working

Home Forums RetroPie Project Controller Configuration in RetroPie Save & Load not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 11 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 1 year, 11 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #98369
    Profile photo of undreamed
    undreamed
    Participant

    I setup the new 3.0 .. all works fine. Great work. But the hotkey for save and load dont work =/ all others select + start and others works… okay… select + b exit the gba emulator.. but its okay…

    Can any1 tell me why save&load not work? i use a generic usb controller and its configured:`input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_menu_toggle_btn = “0”
    input_load_state_btn = “4”
    input_save_state_btn = “5”
    input_reset_btn = “2”
    input_state_slot_increase_axis = “+0”
    input_state_slot_decrease_axis = “-0”
    `

    #98379
    Profile photo of Floob
    Floob
    Moderator

    Do they work if you hold select, then press F2 and F4 for save and load?
    Just want to check they work at all first.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98383
    Profile photo of undreamed
    undreamed
    Participant

    okay select+F2/F4 works… but why didnt work my gamepad?

    #98386
    Profile photo of patl
    patl
    Participant

    You must phush the hotkey button (select as Floob wrote ?) and then the buttons for save and load.

    #98387
    Profile photo of undreamed
    undreamed
    Participant

    i push/hold select and push “L” or “R” for save & Load.. but nothing happends

    #98388
    Profile photo of Floob
    Floob
    Moderator

    This may help:
    http://blog.petrockblock.com/forums/topic/usb-snes-controller-d-pad-not-working-in-games/#post-97091

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98390
    Profile photo of undreamed
    undreamed
    Participant

    okay.. i see the problem.. but not the solutionl…. my gamepad is configured correctly withe config tool… but ingame… L/R doesnt work… why?

    #98392
    Profile photo of Floob
    Floob
    Moderator

    Have you deleted all the .cfg files then recreated it as detailed in the link? That has worked for at least 3 others on the forum.

    I think there is a conflict somewhere between one or more of the auto config files (that deal with the usbgamepad you have). I could be wrong, but removing them and recreating the one you want seems to work.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98394
    Profile photo of undreamed
    undreamed
    Participant

    it works! i delet all configs and make new šŸ˜‰ TY !!!!

    #98395
    Profile photo of Floob
    Floob
    Moderator

    I think it may have been an issue with this file:
    Retrolink_USB_SEGA_Saturn_Classic_Controller.cfg

    If just that one is deleted it may have worked as well.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98396
    Profile photo of undreamed
    undreamed
    Participant

    okay.. but the problem with restart the gba emulator with select+b issnt solved with this “fix”… any1 an idea?

    • This reply was modified 1 year, 11 months ago by Profile photo of undreamed undreamed.
    #98398
    Profile photo of Floob
    Floob
    Moderator

    Can you open a new thread for the GBA issue and I’ll take a look.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 12 posts - 1 through 12 (of 12 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar