running LumberJacks mk_arcade GPIO joystick driver at boot time?

Home Forums RetroPie Project Controller Configuration in RetroPie running LumberJacks mk_arcade GPIO joystick driver at boot time?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of jbfortune jbfortune 1 year, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #114916
    Profile photo of seriouslee
    seriouslee
    Participant

    Ive soldered everything up, installed the driver, ran the driver with “sudo modprobe mk_arcade_joystick_rpi map=1” , and tested it successfully with “jstest /dev/input/JS3”.

    but adding “mk_arcade_joystick_rpi map=1” into /etc/modules wont start the joystick at boot time. it only gets recognized when i run the sudo modprobe command manually, which makes me think i messed up in the /etc/modules config.

    /etc/modules: kernel modules to load at boot time.
    
    This file contains the names of kernel modules that should be loaded at boot time, one per line. Lines beginning with "#" are ignored. Parameters can be specified after the module name.
    
    snd-bcm2835
    
    #i2c-bcm2708
    
    #i2c-dev
    
    mk_arcade_joystick_rpi map=1

    grem75 on reddit helped me to “kinda” get the joystick to run at boot time by creating a joystick.conf file in /etc/modprobe.d/ , and put the line
    options mk_arcade_joystick_rpi map=1 in there, and just have the module name without parameter in /etc/modules, like this:

    snd-bcm2835
    #i2c-bcm2708
    #i2c-dev
    mk_arcade_joystick_rpi
    

    well, the joystick runs now at boot time, but the joystick up switch is getting triggered like a rapid fire button without even touching it. i have even de-soldered it to see if it is related to it.

    
    Axes:  0:     0  1:     0 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off 6:
    Axes:  0:     0  1:-32767 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off 6:
    Axes:  0:     0  1:     0 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off 6:
    Axes:  0:     0  1:-32767 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off 6:
    Axes:  0:     0  1:     0 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off 6:
    Axes:  0:     0  1:-32767 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off 6:

    when i remove /etc/modprobe.d/joystick.conf, and load the joystick manually with “sudo modprobe mk_arcade_joystick_rpi map=1” , the joystick behaves normaly, i can even play games with it.

    so how is any of this related to the weird behavior the joystick is showing, and how would i get it properly to work at boot time?

    • This topic was modified 1 year, 3 months ago by Profile photo of seriouslee seriouslee.

    #115743
    Profile photo of jbfortune
    jbfortune
    Participant

    Hey.

    I have this exact issue. It used to work on the 3.0 but the latest update won’t work!

    Any one got any ideas?

    Thanks,

    Jason

    #115744
    Profile photo of jbfortune
    jbfortune
    Participant

    Nvm, I found your reddit post where you said you put in sudo modprobe mk_arcade_joystick_rpi map=1 into the rc.local.

    That worked for me too! Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar