RetroPie / OpenELEC (KODI) Dual Boot Disc Image

Home Forums RetroPie Project New to RetroPie? Start Here! RetroPie / OpenELEC (KODI) Dual Boot Disc Image

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 370 replies, has 46 voices, and was last updated by Profile photo of buzz buzz 1 year, 5 months ago.

Viewing 35 posts - 316 through 350 (of 371 total)
  • Author
    Posts
  • #106303
    Profile photo of smithers
    smithers
    Participant

    Hi.

    Sorry for the lack of replies. Been busy with the triple boot. It has had my head absolutely done in trying to sort out transparency in Cairo-Dock using xcompmgr, but I have eventually figured it out and happy to say it is now running perfect on all systems!

    I have calculated the minimum partition sizes for each OS too:

    OpenELEC = 1.8GB – this awards enough space should you wish to install the ‘Beast Build’ (I have added the Spartan Wizard program so it is ready to install via 1 click, should you want to). I have also set up this build so you will be presented with the standard ‘Welcome Wizard’ within OpenELEC on first run, so you can set up some of your own preferences.

    Raspbian = 6GB – this allows approx 1.5GB free space. Quite large but nothing I can do. I have installed the following to Raspbian:

    Libre Office (Word, Excel, PowerPoint… the full suite of MS equivalents)
    VLC Media Player
    Chromium
    GIMP (image manipulation tool)
    Cairo-Dock (my arch nemesis)
    ….maybe more that I have forgot too.

    RetroPie = the rest of the space available on your card (minimum 2.8GB).

    So by my calculations you should be able to install on a 16GB SD card and have approx 7GB storage space available to RetroPie (this is me estimating how much card space is lost due to boot partitions and NOOBS recovery files). Not too bad really, in theory, but this is of course assuming you take the ‘Install from USB stick’ method (massively recommended for all my builds, especially this monster!).

    So now all I have to do is compress all partitions down so they are ready for the NOOBS installer but this will take an age given how big the files are in this build, so I’ll leave it over night to do its thing as its too late now (again!!). This means I won’t be able to test it until tomorrow night when I’m home from work, but I’ll definitely aim to release tomorrow night, all being well.

    I’ll reply to questions above tomorrow.

    All the best.
    Steve

    #106308
    Profile photo of dnarjen
    dnarjen
    Participant

    Hi.

    Sorry for the lack of replies. Been busy with the triple boot.

    Hi,

    This will turn the RPi into a full ‘one-size fits all’ solution.

    As always, thanks for all your time and effort.
    Can’t wait to try this out!

    Cheers!

    #106310
    Profile photo of smithers
    smithers
    Participant

    The problem is that i do not have controller any more (the other ports like doom, quake, play normally). A yellow text for XBox controller also appears. Any thoughts?

    Very strange. The wadfile is running via lr-prboom which is a retroarch emulator therefore the controls should work just fine? Especially since you are seeing the yellow text, which would indicate your pad has been detected (I assume you have an Xbox pad!). I would suggest going into the retroarch GUI when in the game (normally via F1 key, or ‘hotkey+F1’) and setting up the controls manually, see if that works. If it does, then save a config file which you can then rename to retroarch.cfg and place in the lr-prboom folder for it to load when prboom is loaded. Should sort you out.

    #106311
    Profile photo of smithers
    smithers
    Participant

    1) i see on your youtube channel (https://www.youtube.com/watch?v=HxjabijmIWM) that you have managed to run OPENBOR in RetroPie (2 games). Are y planning on updating your image with this engine? Some games look great !!

    Yes I thought openbor was a great addition but it wasn’t very well received when I made a post about it haha! I assume its just one of these less heard of community driven game engines. Nevertheless I do already include it in my builds – look in the ports section and you will find Goldenaxe Remake and Double Dragon Extreme – these are both Openbor mods and are both very good. I didn’t want to overload with the bor mods so figured I would add 2 good ones and then at least the foundations are there for you to add more at your own will. I made a post on these forums somewhere detailing my method of adding mods to openbor so they will appear in the es menu. It also includes a Mega link full of mods!

    #106312
    Profile photo of smithers
    smithers
    Participant

    Hello!

    I was trying to repartition the sd card.. i have a 16 gb partition, and would like to have the openelec partition 6 gb (for plugins and streaming with pulsar) and the rest the retropie..

    i tried with gparted, but it doesnt let me move the last partition (32 mb) and wihtout moving that partition I cannot resize openelec.

    Any Idea on how to procede?

    Thanks!

    Hi.

    I’m afraid this can’t be done. If you look back through this thread it has been asked a few times. NOOBS handles all partitioning at first install so if you need to make changes it has to be done prior to installation.

    I will make an instruction manual on doing this in time however if you look on the NOOBS website it should detail how to do it there already.

    #106313
    Profile photo of haris1977
    haris1977
    Participant

    look in the ports section and you will find Goldenaxe Remake and Double Dragon Extreme – these are both Openbor mods and are both very good

    Thanks Smithers. Am i the only one that thinks that “Goldenaxe Curse of Death Adder” should be implemented in your “new” build? Is it possible? It is much much better than the classical golden axe !! (even better from the golden axe remake-openbor) 🙂

    Looking forward to it!

    #106315
    Profile photo of smithers
    smithers
    Participant

    look in the ports section and you will find Goldenaxe Remake and Double Dragon Extreme – these are both Openbor mods and are both very good

    Thanks Smithers. Am i the only one that thinks that “Goldenaxe Curse of Death Adder” should be implemented in your “new” build? Is it possible? It is much much better than the classical golden axe !! (even better from the golden axe remake-openbor) :)

    Looking forward to it!

    Well its funny you should say that as it was actually me who made the ‘Goldenaxe – Curse of Death Adder’ mod! I released 3 demos of it but never could give enough time to finish it off so abandoned it, unfortunately. Somebody else picked up where I left off but they ruined it and it lost the feel and look that I was trying to achieve (they even removed the Conan the Barbarian theme music I put on!!). A few people have borrowed from it for their own goldenaxe mods too I noticed, which is cool. I still have my original ‘final demo’ version, should you want it, but I didn’t include it in my build as it was unfinished. It is the version that you see in my video.

    #106317
    Profile photo of sharkyenergy
    sharkyenergy
    Participant

    gggggreat project!

    Love the tripleboot and cant wait to download it.. is it possible to change the partition sizes before installing? is there just a file to edit or is it hardcoded?

    Thanks!

    • This reply was modified 1 year, 6 months ago by Profile photo of sharkyenergy sharkyenergy.
    #106320
    Profile photo of candyluv
    candyluv
    Participant

    Hi.

    Sorry for the lack of replies. Been busy with the triple boot. It has had my head absolutely done in trying to sort out transparency in Cairo-Dock using xcompmgr, but I have eventually figured it out and happy to say it is now running perfect on all systems!

    I have calculated the minimum partition sizes for each OS too:

    OpenELEC = 1.8GB – this awards enough space should you wish to install the ‘Beast Build’ (I have added the Spartan Wizard program so it is ready to install via 1 click, should you want to). I have also set up this build so you will be presented with the standard ‘Welcome Wizard’ within OpenELEC on first run, so you can set up some of your own preferences.

    Raspbian = 6GB – this allows approx 1.5GB free space. Quite large but nothing I can do. I have installed the following to Raspbian:

    So now all I have to do is compress all partitions down so they are ready for the NOOBS installer but this will take an age given how big the files are in this build, so I’ll leave it over night to do its thing as its too late now (again!!). This means I won’t be able to test it until tomorrow night when I’m home from work, but I’ll definitely aim to release tomorrow night, all being well.

    I’ll reply to questions above tomorrow.

    All the best.
    Steve

    Hi Smither,

    Such great work. Not enough words to express how happy I am for it.
    In terms of OpenELEC = 1.8GB, what about the 0-cache option where cache is stored on the card will the 1.8GB limit it?
    As for me using a 32GB card will the 22GB automatically go to the retropie or will it be divided between all partitions?

    And great great again. You are a BOSS.

    #106322
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    What is the username and password to SFTP into kodi?

    i want to change some of the skin settings.

    Thx

    #106323
    Profile photo of haris1977
    haris1977
    Participant

    Well its funny you should say that as it was actually me who made the ‘Goldenaxe – Curse of Death Adder’ mod! ….. I still have my original ‘final demo’ version, should you want it, but I didn’t include it in my build as it was unfinished. It is the version that you see in my video.

    Yeah it was you you made it, forgot to mention it:) I ve already download it to my pc (openbor) and YES i would like to see it (the graphics are gorgeous!) in your next release (with an *.shh extension i suppose).

    🙂

    #106324
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    I’ve reinstalled the image again

    Amiga emulator definitely doesn’t work.

    #106325
    Profile photo of haris1977
    haris1977
    Participant

    What is the username and password to SFTP into kodi?

    i want to change some of the skin settings.

    user: root password: openelec (through ssh)

    #106329
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    What is the username and password to SFTP into kodi?

    i want to change some of the skin settings.

    user: root password: openelec (through ssh)

    Thanks a lot, worked a treat.

    I want to remove the karaoke option 🙂

    When I click tv/movies, it comes up with a myriad of plugins/addons which is cool, but i have to press back a cpl of times, and then title to get to my tv shows or films from nas drives.

    Is there a way to make these top level from tv/movies?

    • This reply was modified 1 year, 6 months ago by Profile photo of ukbootlegs ukbootlegs.
    • This reply was modified 1 year, 6 months ago by Profile photo of ukbootlegs ukbootlegs.
    #106334
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    Smithers, just an FYI

    It’s the 800mb dual boot image that we extract to sd card rather than the 3.7gb image you burn that doesn’t have a working amiga emulator.

    It worked on the larger image

    #106335
    Profile photo of haris1977
    haris1977
    Participant

    Ukbootlegs have y tried re-installing the amiga emulator (uae4all not uae4arm) from the retropie setup script?

    I did have problems with smither’s default amiga emulator (uae4arm) and revered back to the old one.

    #106340
    Profile photo of haris1977
    haris1977
    Participant

    When I click tv/movies, it comes up with a myriad of plugins/addons which is cool, but i have to press back a cpl of times, and then title to get to my tv shows or films from nas drives.

    Is there a way to make these top level from tv/movies?

    You may go into movies and then go back into “files=>add videos”, find your nas server through nfs and add it to your favorites (by pressing c in keyboard)

    Hope that helps

    #106405
    Profile photo of robertus
    robertus
    Participant

    but with this, you must go into favorites, and not in movies.

    there is a way to go in movies and see our files, without go back and then select the nas folder?

    (example: go into movies and see all movies posters in nas )

    #106406
    Profile photo of robertus
    robertus
    Participant

    There is a little problem in Retropie Arcade:

    If you update all emulators or also some of them, like mame4all that have the controller ps3 problem in wireless ( fixed if you update the emulator ), the update of course works only in \\RETROPIE\roms\mame-mame4all, and not in \\RETROPIE\roms\arcade.

    I think that is possible fix it with copy and paste mame4all files.

    Smithers you know how? If you have some minutes to dedicate about this little problem.

    Thanks for you amazing job

    #106467
    Profile photo of sharkyenergy
    sharkyenergy
    Participant

    Amiga emulator is working fine for me on the 800 mb one..

    Any news on the release date of the triple boot? Got my new pi there sitting and waiting.. 😀

    #106489
    Profile photo of smithers
    smithers
    Participant

    Quick post before I go to bed. Just to say I have the triple boot up and running and it works a treat. Was a lot easier than expected.

    …..OK so I couldn’t have been more wrong. This triple boot build has been an absolute nightmare to package up and I have faced issues at every point along the way! Partition numbers changed, ‘sudo’ command was lost, os launching scripts wouldnt work, standard Raspbian partitioning script wouldn’t work, Cairo-Dock transparency issues… think of something that could have gone wrong and it did. >:(

    Good news is that I have finally sorted all issues out and its ready to go. Here is a Google Drive link:

    https://drive.google.com/file/d/0BzXFP_d3CHStelJpZDc5ZndlTlk/view?usp=sharing

    I will post a new thread for this in the forum – please ask any questions there so not to mix up this thread.

    Cheers.
    Steve

    #106491
    Profile photo of haris1977
    haris1977
    Participant

    Smithers

    Have y added “Goldenaxe – Curse of Death Adder” in game ports?

    #106494
    Profile photo of smithers
    smithers
    Participant

    I’ve made no changes to RetroPie other than adding a Raspbian theme and script. I didn’t see the need to add another Golden Axe mod as standard (especially one that is not finished!).

    OpenBOR mods can be added easily if you copy the directory structure I have put in place for the 2 existing mods in my build.

    #106506
    Profile photo of evaspaceman
    evaspaceman
    Participant

    Thanks for the triple boot image. I’m really looking forward to getting everything up and running. Unfortunately, I have run into a problem. I can not get wifi configured. The dhcpcdgui doesn’t seem to work (will not display any network SSIDs – wlan0 not associated). In addition, I can not get it working manually. The ifup and ifdown commands are not recognized/valid. Any suggestions. I am using an EDIMAX ew-7811un adapter which seems to work on the default Raspbian builds.

    #106576
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    Ukbootlegs have y tried re-installing the amiga emulator (uae4all not uae4arm) from the retropie setup script?

    I did have problems with smither’s default amiga emulator (uae4arm) and revered back to the old one.

    Can you explain how to do that? I am not familiar with pi or Linux to be honest.

    #106578
    Profile photo of haris1977
    haris1977
    Participant

    Go into retropie setup script from within emulation station specific tab.

    Then go to install individual emulators from binary/source, and choose uae4all.

    #106589
    Profile photo of will5wp
    will5wp
    Participant

    Thanks for the triple boot image. I’m really looking forward to getting everything up and running. Unfortunately, I have run into a problem. I can not get wifi configured. The dhcpcdgui doesn’t seem to work (will not display any network SSIDs – wlan0 not associated). In addition, I can not get it working manually. The ifup and ifdown commands are not recognized/valid. Any suggestions. I am using an EDIMAX ew-7811un adapter which seems to work on the default Raspbian builds.

    Hi there – just to report I have the same issue

    #106669
    Profile photo of smithers
    smithers
    Participant

    Hi.

    Please post ‘triple-boot’ related questions in the triple boot thread I created, just so it doesn’t get lost in this thread or cause confusion.

    I have posted a reply in that thread regarding WiFi issues.

    Cheers
    Steve

    #106689
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    Go into retropie setup script from within emulation station specific tab.

    Then go to install individual emulators from binary/source, and choose uae4all.

    Thx

    • This reply was modified 1 year, 6 months ago by Profile photo of ukbootlegs ukbootlegs.
    #106694
    Profile photo of ukbootlegs
    ukbootlegs
    Participant

    Harris and smithers

    thanks for your image and help

    I am a sad middle aged man playing Gods on the amiga again 🙂

    #106708
    Profile photo of smithers
    smithers
    Participant

    Harris and smithers

    thanks for your image and help

    I am a sad middle aged man playing Gods on the amiga again :)

    Haha, nothing wrong with that! I used to love Gods although I had it on the Atari ST rather than Amiga. I will get round to actually playing games myself one day. I spend more time tweaking things than I do playing :/

    #106886
    Profile photo of xd3l
    xd3l
    Participant

    Awesome, thank you for doing this! This is one of those things I was wanting to figure out how to do on my own as running Kodi from within a RetroPie boot isn’t nearly as reliable as running it from the OpenElec distro.

    I’m downloading now, thanks for the huge time saver!

    #106980
    Profile photo of danfaraday
    danfaraday
    Participant

    Hi Smithers, are you planning to update your OSMC+retropie build? I really prefer OSMC over OpenElec and your last build doesn’t have a stable retropie version. That would be awesome. Anyway congratulations for you good work!

    #106981
    Profile photo of dukevindzor
    dukevindzor
    Participant

    Brilliant work, just what I needed! 🙂

    • This reply was modified 1 year, 6 months ago by Profile photo of dukevindzor dukevindzor.
    #106990
    Profile photo of smithers
    smithers
    Participant

    Hi Smithers, are you planning to update your OSMC+retropie build? I really prefer OSMC over OpenElec and your last build doesn’t have a stable retropie version. That would be awesome. Anyway congratulations for you good work!

    I can do yes – you are the first to ask for it so I’m assuming most folk are happy with OpenELEC (as am I), but I can easy make a new OSMC image up should you want it.

    Can I ask – did you try my OSMC build? If so, are there any changes you would recommend? I am not familiar with OSMC so I left it as-is in my build, but to me the menu system looked really basic – is this the attraction to OSMC or is there a standard set of customizations that folk generally apply to OSMC that I could pre-install?

    Hope that makes sense!?

    Cheers.
    Steve

Viewing 35 posts - 316 through 350 (of 371 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar