RetroPie Load Save Rom Data

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 34 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 2 months ago.

Viewing 35 posts - 1 through 35 (of 35 total)
  • Author
    Posts
  • #86133
    Profile photo of sten23
    sten23
    Participant

    this is my file in the “/opt/retropie/configs/snes” the retroarch.cfg file is
    —————–RETROARCH.CFG—————

    # All settings made here will override the global settings for the current emulator core

    video_shader = “/opt/retropie/emulators/RetroArch/shader/snes_phosphor.glslp”

    video_shader_enable = “false”
    video_smooth = “false”

    savestate_auto_save = “false”
    savestate_auto_load = “true”
    savefile_directory = “/home/pi/RetroPie/roms/snes”
    savestate_directory = “/home/pi/RetroPie/roms/snes
    video_font_size = “20.0000”

    input_state_slot_increase = “i”
    input_state_slot_decrease = “o”
    input_player1_joypad_index = “0”
    input_player1_b_btn = “2”
    input_player1_a_btn = “1”
    input_player1_y_btn = “3”
    input_player1_x_btn = “0”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_start_btn = “9”
    input_player1_select_btn = “8”
    input_player1_l_y_plus = “-1”
    input_player1_up_axis = “-1”
    input_player1_l_y_minus = “+1”
    input_player1_down_axis = “+1”
    input_player1_l_x_minus = “-0”
    input_player1_left_axis = “-0”
    input_player1_l_x_plus = “+0”
    input_player1_right_axis = “+0”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_enable_hotkey_btn = “8”
    input_state_state_btn = “4”
    input_enable_hotkey_btn = “8”
    input_load_state_btn = “5”
    ——-END—OF—-RETROARCH.CFG————–

    the games load as they start in SNES emulator but when I try to save and load the game it wont allow me to load it saying it failed

    the Roms are in

    /home/pi/RetroPie/roms/snes

    im not sure what to do all I want for right now is to play SNES on the raspberry pi and be able to save and load my game data.

    Any Help?
    If you need more Info reply and ill respond.

    #86163
    Profile photo of Floob
    Floob
    Moderator

    Do you have the full error message?
    Maybe its permissions writing to your rom folder?

    This may also help:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86164
    Profile photo of sten23
    sten23
    Participant

    It says something along the lines of could load save data from the following folder and it shows the whole file structure where i have the roms in.

    Im not sure how to check the permissions I thought I had already done that because I don’t think saved data hasnt even been creating.
    How do I check this?

    #86165
    Profile photo of Floob
    Floob
    Moderator

    In 2.4.2 there is an option in the RetroPie setup script to check permissions, its under the Setup menu in there.
    Or use Filezilla and set everything in the roms dir to 777.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86166
    Profile photo of sten23
    sten23
    Participant

    Ill check once Im home, around 6PM about 7 hours from now you will get a respond from me!

    #86172
    Profile photo of sten23
    sten23
    Participant

    I have RetroPie 2.0.0 how do I get 2.4.2? I keep trying to find it but keep finding broken links.

    The error is Failed to load state from ‘home/pi/RetroPie/roms/snes/romGammmeehere.

    I think it might be easier to update to 2.4.2 to be on the most current version and check the file permission. Can I get a link to 2.4.2 and something else I can do for this error message?

    #86173
    Profile photo of Floob
    Floob
    Moderator

    You can get 2.4.2 here:
    http://blog.petrockblock.com/retropie/retropie-downloads/download-info/retropie-sd-card-image-v2-4-2-beta/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86175
    Profile photo of sten23
    sten23
    Participant

    I downloaded and installed it and it says V2.0.0 in Main Menu??

    #86176
    Profile photo of Floob
    Floob
    Moderator

    Maybe you’re looking at EmulationStation – thats v2.
    As long as you used that link above its fine.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86177
    Profile photo of sten23
    sten23
    Participant

    Im writing the image to the usb so ill see right now and I also downloaded the torrent version so that’s last hope.

    #86181
    Profile photo of sten23
    sten23
    Participant

    I downloaded it twice and its 2.0.0 I don’t know what I did wrong.

    #86182
    Profile photo of sten23
    sten23
    Participant

    Can you give me the exact link because I clicked downloaded on bottom of the donate button and the torrent link for this site http://blog.petrockblock.com/retropie/retropie-downloads/download-info/retropie-sd-card-image-v2-4-2-beta/
    and both times when I go to the MAIN MENU after flashing it to the sd card it says

    EMULATIONSTATION V2.0.0-RC1

    #86193
    Profile photo of Floob
    Floob
    Moderator

    Thats right. Its RetroPie 2.4.2 and EmulationStation v2.0.0
    Its the right file you have.

    In the setup script here:
    /home/pi/RetroPie-Setup/retropie_setup.sh

    run it with
    sudo ./retropie_setup.sh

    On the first screen choose “Update RetroPie Setup Script”
    Then quit out and re-run it

    Then choose option 3 Setup
    Then option 315 would reset permissions, but if you have just built the image it should be fine.

    Just make sure you copy roms across using the “pi” user. It should be fine.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86194
    Profile photo of sten23
    sten23
    Participant

    How do I know if its 2.4.2 I ran the script but it said something about not having enough space. Now I can’t put the roms back in the pi Im doing the usb method which copys folder and I copy the roms into them and plug it into the pi and it should copy them over.

    #86195
    Profile photo of Floob
    Floob
    Moderator

    I’d suggest following this from scratch (except use 2.4.2 as you are doing)
    You are using 2.4.2. Its the only one available at that link you followed above.

    The guide includes how to expand your card first.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86196
    Profile photo of sten23
    sten23
    Participant

    Lol dang. alright I just installed the roms into it and it was still saying the same error message while some new info popped up on screen this build like joypad or something and press x or n or something like that and it went to the rom and played. I think im getting there ima follow it from scratch and message back. Thanks for the help so far.

    #86197
    Profile photo of sten23
    sten23
    Participant

    There I did all the steps in the video and I still get the same error message when Im trying to load a game data.

    #86211
    Profile photo of Floob
    Floob
    Moderator

    Can you confirm you expanded the card?

    What does the command “df -h” return?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86240
    Profile photo of sten23
    sten23
    Participant

    Theres picture included.

    #86241
    Profile photo of sten23
    sten23
    Participant

    Included a picture

    Attachments:
    #86243
    Profile photo of Floob
    Floob
    Moderator

    Ok, plenty of space there. Can you screenshot the error you get and confirm what you do to get the error? Do you press F4 to load a game? I presume you have saved a game first?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86244
    Profile photo of sten23
    sten23
    Participant

    I put back the snes retroarch.cfg file im using a snes usb pad when i get into the game i click the Save state buttons then the load then I get this error message. The exit buttons on my pad do work though.

    Attachments:
    #86252
    Profile photo of Floob
    Floob
    Moderator

    Can you update the line in this file
    /opt/retropie/configs/all/retroarch.cfg

    to read
    video_font_size = 16

    make sure it doesnt have a # in front of it. It will help to confirm the full filename that is being attempted to load.

    Can you also screenshot the text that comes up when you save a game?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86278
    Profile photo of sten23
    sten23
    Participant

    Alright ill check the pound sign in retroarch.cfg file but I do know that nothing comes up when I save the file no text appears only for the error message saying it can’t load it.

    #86284
    Profile photo of Floob
    Floob
    Moderator

    You should get a message when saving, otherwise its probably not saving. The first video above shows this.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86340
    Profile photo of sten23
    sten23
    Participant

    I think I already have a line similar to that. In my code I have the line to save I dont know if thats the problem or something else

    Attachments:
    #86346
    Profile photo of Floob
    Floob
    Moderator

    You have an entry state_state there? I think that’s a typo – you mean save?
    And you only need to have the hotkey enable line once. You could set shader to true whilst you’re there.
    You could try using the F2 key when you press select as well.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86347
    Profile photo of sten23
    sten23
    Participant

    The hotkey is there for three different combinations a save state, load state, and exit emulator. ima try fixing some code and see what happens

    #86360
    Profile photo of sten23
    sten23
    Participant

    I did some things for the savestate_state idk what line you were talking about this time instead of exit being fist combo i moved it down to test if the save file works being the first combination. Or at least seeing a error message.

    Attachments:
    #86362
    Profile photo of sten23
    sten23
    Participant

    This config setup didnt show the error code or nothing when saving when I went back to the config file I saw the state_state in the file so I changed it set one hotkey followed by the other event buttons. And I set save_state first to see if it at least saves or what now. Muahahahah ITS ALIVE! I changed it and now it saves exits and loads succesfuly all three times showing a line of code on the emulator thanks a bunch. Now ima make it more accesible and slowly add more commands thanks.

    #86397
    Profile photo of Floob
    Floob
    Moderator

    Thats good news. But I would still take out your multiple enable hotkey lines. It only needs to be there once. Even if you have multiple hotkeys.

    Plus, ideally you should only put settings that are specific to the snes emulator in your file in that directory – if you want to use the same controller for all emulators you could put these details in you auto controller file instead.

    If you get bored, check out my videos that cover hotkeys and controllers.
    Link in signature.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86697
    Profile photo of sten23
    sten23
    Participant

    How would you connect the pi to dvi monitor i have a hdmi to dvi but the screen doesnt show anything

    #86700
    Profile photo of Floob
    Floob
    Moderator

    Check out the DMT modes here:
    http://elinux.org/RPiconfig#Video

    These are settings for /boot/config.txt

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #89008
    Profile photo of sten23
    sten23
    Participant

    For retropie how do you remove or hide some emulators from appearining or how do you change the starting emulator? Also I have been trying to change back the audio to hdmi and havent been able to i tried sudo raspi-congif and setting the audio to auto next ima set it to hdmi and see if it works im just scrapping all the roms for info so I cant do so right now.

    #89110
    Profile photo of Floob
    Floob
    Moderator

    To hide emulators, just delete files found in /home/pi/RetroPie/roms/{systemname}/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 35 posts - 1 through 35 (of 35 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar