RetroPie GBA Not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of rupee990 rupee990 2 years, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #91204
    Profile photo of rupee990
    rupee990
    Participant

    Hello, I have been working 2 days on this and reinstalled retroppie 2 times.

    Iam trying to run GBA roms, but when I open them it only says the following:

    /opt/retropie/supplementary/runcommand/runcommand.sh: line 304: 2406 illegal instruction /opt/retropie/emulators/gpsp/gpsp /home/pi/RetroPie/roms/gba/Pokemon\ -\ Fire\red\ Version\(USA).gba

    I updated my binairies…all my paths in the es_configs are fine..

    Here is the one from etc/emulationstation/es_config.cfg:

    <system>
    <fullname>Game Boy Advance</fullname>
    <name>gba</name>
    <path>~/RetroPie/roms/gba</path>
    <extension>.gba .GBA</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 1 “/opt/retropie/emulators/gpsp/gpsp %ROM%” “gpsp”</command>
    <platform>gba</platform>
    <theme>gba</theme>
    </system>

    I do not know what to do anymore I have tried everything I found on the web…

    GBAbios: Gba_Bios.bin
    retropie version: v2.6.0-rpi2
    raspberry: raspberry pi 2 B+ ( 1gb Ram; 900Mhz Quad ARm)

    #91224
    Profile photo of rupee990
    rupee990
    Participant

    I have now tried to Run gpsp from its file

    I went to: /opt/retropie/emulators/gpsp

    and and tried: sudo ./gpsp

    it didnt tell me nothing it just went to a new Entry line.

    Tried to run GBA afterwards and still the illegal instruction error.
    ======================================================================
    Another thing I have tried is Update my gpsp files.

    but it gives me a following error:

    ../cpu.c:4371:7: warning: variable old_pc set but not used [-Wunused-but-set-variable]

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar