Retropie 3 – wifi TL-WN725N

Home Forums RetroPie Project Everything else related to the RetroPie Project Retropie 3 – wifi TL-WN725N

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 14 replies, has 4 voices, and was last updated by Profile photo of carlux3 carlux3 1 year, 8 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #102357
    Profile photo of carlux3
    carlux3
    Participant

    Hello,

    I installed a retropie 3 on a Rpi2, I’d like to connect it in wifi. I have wifi dongle TP-Link : TL-WN725N which should be working but it doesn’t.
    When I go through the Retropie Wifi Menu it doesn’t detect any wifi network.
    I try to follow some topics here but without success ….
    I try to change the /etc/network/interfaces, but it didn’t change anything :

    auto lo
    
    iface lo inet loopback
    iface eth0 inet dhcp
    allow-hotplug wlan0
    auto wlan0
    #iface wlan0 inet manual
    iface wlan0 inet dhcp
    #wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
    #iface default inet dhcp
    wpa-ssid Numericable-f1f2
    wpa-psk **********

    it seems the wlan0 is not detected.

    Do you have an idea ?

    #102360
    Profile photo of herbfargus
    herbfargus
    Moderator

    Did you try this:
    http://blog.petrockblock.com/forums/topic/no-wireless-networks-found/

    Is your encryption WPA or WEP? Your interfaces file will be different depending on your encryption.

    #102365
    Profile photo of carlux3
    carlux3
    Participant

    Hello,

    Yes I did but it doesn’t help.

    My encryption was : WPA-PSK [TKIP] + WPA2-PSK [AES] and changed it to WPA2-PSK [AES] and then to WPA-PSK [TKIP] but nothing changed

    if I do a ifconfig, the wlan0 doesn’t appear.

    Do I need to put the SSID and pasword between “” ?

    if I do ifup wlan0 :

    pi@retropie ~ $ sudo ifup wlan0
    wpa_supplicant: wpa-roam can only be used with the "manual" inet METHOD
    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
    Internet Systems Consortium DHCP Client 4.2.2
    Copyright 2004-2011 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    
    Cannot find device "wlan0"
    Bind socket to interface: No such device
    Failed to bring up wlan0.
    • This reply was modified 1 year, 9 months ago by Profile photo of carlux3 carlux3.
    • This reply was modified 1 year, 9 months ago by Profile photo of carlux3 carlux3.
    • This reply was modified 1 year, 9 months ago by Profile photo of carlux3 carlux3.
    #102370
    Profile photo of herbfargus
    herbfargus
    Moderator

    Typically mine has double quotes like the example listed under option 2 here:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-Up-Wifi

    See if adding double quotes changes anything.

    #102371
    Profile photo of herbfargus
    herbfargus
    Moderator

    If its not even showing try sudo ifconfig wlan0 up

    #102373
    Profile photo of carlux3
    carlux3
    Participant

    Typically mine has double quotes like the example listed under option 2 here:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-Up-Wifi
    See if adding double quotes changes anything.

    it doesn’t change anything

    If its not even showing try sudo ifconfig wlan0 up

    see result below :

    pi@retropie ~ $ sudo ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device
    • This reply was modified 1 year, 9 months ago by Profile photo of carlux3 carlux3.
    • This reply was modified 1 year, 9 months ago by Profile photo of carlux3 carlux3.
    #102376
    Profile photo of herbfargus
    herbfargus
    Moderator

    sounds like its a driver issue then rather than your configurations. seems you’re not the only one who has had issues with the same wifi dongle:

    https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371&start=475

    #102377
    Profile photo of herbfargus
    herbfargus
    Moderator

    from that forum link I posted you could try this:
    sudo wget https://github.com/lwfinger/rtl8188eu/raw/c83976d1dfb4793893158461430261562b3a5bf0/rtl8188eufw.bin -O /lib/firmware/rtlwifi/rtl8188eufw.bin

    sudo reboot

    and then use wpa supplicant along with interfaces detailed here:
    http://www.fars-robotics.net/

    #102384
    Profile photo of buzz
    buzz
    Keymaster

    I would just buy a new wireless dongle, one that has a well supported chipset. No point fighting each time with drivers when you can pick them up for a few pounds.

    #102386
    Profile photo of muffy
    muffy
    Participant

    On my old RP1 i had a TL-WN725N too.
    You have to install the driver manually and every time again after a stystem update.

    #102391
    Profile photo of carlux3
    carlux3
    Participant

    Thanks, but still nothing :'(

    #102392
    Profile photo of carlux3
    carlux3
    Participant

    On my old RP1 i had a TL-WN725N too.
    You have to install the driver manually and every time again after a stystem update.

    can you tell which driver you use and how you install it ?

    cheers

    #102459
    Profile photo of muffy
    muffy
    Participant

    Press F4 and read your actual Linux version.
    For example Linux 3.12.22+.
    Then you have to google for the driver. Every new Linux version needs an own driver for the TL-WN725N.

    For the installing i used this tutorial:

    #102460
    Profile photo of muffy
    muffy
    Participant
    #103293
    Profile photo of carlux3
    carlux3
    Participant

    Unfortunatly nothing works … I’ll see to buy a new dongle…

    Thanks

Viewing 15 posts - 1 through 15 (of 15 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar