RetroPie 3.3, F310, fresh install, no dice [solved-so far]

Home Forums RetroPie Project Controller Configuration in RetroPie RetroPie 3.3, F310, fresh install, no dice [solved-so far]

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of taa11 taa11 1 year, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #112679
    Profile photo of jpeake
    jpeake
    Participant

    Could not get Logitech F310 to work in 3.3. ES detected fine, but got yellow warning message when launching any games. After some trials and errors, this is working.

    1) Logitech F310 in X mode
    2) Get the SD image of 3.3 Wheezy (was using 3.3 Jessie from a Raspian install)
    3) install Xbox driver
    4) Reboot
    5) make sure lsusb sees controller
    6) Make sure jstest passes (I have one 310 plugged in but see two devices, js0 and js1)
    7) configure buttons when ES starts
    8) leave driver at udev in generated .cfg file

    All seems well. Could not get this to work when running 3.3 from Raspian Jessie that I had installed with NOOBS. Using the SD image, seems to have better luck.

    #112681
    Profile photo of Nima
    Nima
    Participant
    #112684
    Profile photo of jpeake
    jpeake
    Participant

    it seems to handle two X F310’s as well. Just needs a reboot when connecting the second controller. No button setup was required for the 2nd one. After reboot, was good to go

    #112685
    Profile photo of taa11
    taa11
    Participant

    I am currently building two of these pi system game emulators with my students:

    http://www.thingiverse.com/thing:667904

    We are using pi2 model B and Retropi 3.3 and using parts from Adafruit, as shown.

    I have the buttons and joystick being recognized in terminal window, but have not yet been successful getting the controls recognized when it boots into emulation station.

    Could someone give me some tips on this?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar