Retropie 3.0 beta retroarch.cfg Issues

Home Forums RetroPie Project Everything else related to the RetroPie Project Retropie 3.0 beta retroarch.cfg Issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 14 replies, has 10 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 7 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #93823
    Profile photo of Zimmy
    Zimmy
    Participant

    Ever since I have updated to the Retropie 3.0 beta, I am having trouble using emulator specific config files. For example, I have tried to change the psx controls in the appropriate retroarch.cfg file, yet it seems that the emulator is still using the universal config file and ignoring the control changes I made. Any help would be appreciated as I am out of ideas.

    #93871
    Profile photo of buzz
    buzz
    Keymaster

    probably the config has the include at the end rather than the beginning. paste your retroarch.cfg for that emulator please /opt/retropie/configs/systemname/retroarch.cfg

    #93872
    Profile photo of ceuse
    ceuse
    Participant

    check your /etc/emulationstation/es_system.cfg file.

    For psx the run command reads

    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 1 "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/psxlibretro/libretro.so --config /opt/retropie/configs/all/retroarch.cfg --appendconfig /opt/retropie/configs/psx/retroarch.cfg %ROM%" "psxlibretro"</command>
    

    check if yours is difrennt / check the path for the appendconfig and edit those config or fiddle around there in general

    #94168
    Profile photo of David
    David
    Participant

    I noticed that the retroarch.cfg for some systems were getting overwritten every time I ran the emulator. I added the following line to the cfg and it stopped getting overwritten.

    config_save_on_exit = “false”

    #94193
    Profile photo of buzz
    buzz
    Keymaster

    i see. We might need to change that then. previously we were using appendconfig to add the additional configs. now it’s included, we don’t want it to be overwritten with a complete config I guess. I’ll open an issue.

    #94258
    Profile photo of PeriodicLogic
    PeriodicLogic
    Participant

    I’m having the same problem. Emulator-specific controller settings don’t seem to be having any affect.

    I vaguely understand that this is based on a change in the way the configuration files are called in the 3.0 betas, but I don’t know if there’s an easy fix. Changing config_save_on_exit doesn’t seem to fix the underlying problem.

    #94280
    Profile photo of Floob
    Floob
    Moderator

    Thats odd – I’ve set some emulator specific settings in the relevant retroarch.cfg and it certainly seems to be reading them. For example I set some specific shader for the Megadrive and it kicks in quite happily.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #94290
    Profile photo of PeriodicLogic
    PeriodicLogic
    Participant

    Perhaps my issue is a different one. I also have some emulator specific settings (such as a specific shader) set in the relevant emulator specific retroarch.cfg that does seem to be active.

    I believe I have four settings in my emulator specific retroarch.cfg:

    The first two are both shader-related, and both seem to be active.

    The second two are different button configurations, and neither seem to be active.

    #94291
    Profile photo of David
    David
    Participant

    In 2.6, my controller file located in /opt/retropie/emulators/retroarch/configs had the following lines which were used:

    input_device = “Microchip Technology Inc. Ultimate 2”
    input_driver = “udev”
    input_up_axis = -1
    input_down_axis = +1
    input_left_axis = -0
    input_right_axis = +0

    In 3.0 Beta 2, this file is no longer read..

    For the Atari 2600 (lr-stella) emulator, I added the lines below.

    #include “/opt/retropie/configs/all/retroarch.cfg”
    config_save_on_exit = “false”
    input_player1_joypad_index = 0
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”

    The file will get rebuilt after running the emulator if I remove the config_save_on_exit. It will add many lines and reformat it. It will keep many, if most/all, of my settings but the config file does get updated.

    Since I wanted it to keep my formatting, I added the config_save_on_exit. This behavior of updating the config file is not in 2.6.

    #94358
    Profile photo of mirage
    mirage
    Participant

    Here’s what I know after spending a few nights testing and trying.

    1 – SYSTEM/retroarch.cfg configs will be considered if you uncomment the following line:
    #include “/opt/retropie/configs/all/retroarch.cfg”

    2 – SYSTEM/retroarch.cfg will be emptied after exiting emulator.

    3 – Adding the following line to the SYSTEM/retroarch.cfg prevents it from being emptied.
    config_save_on_exit = "false"
    ***Be careful about the “” marks when copying command lines from this forum. My browser and/or regional settings are replacing them with similar “” but they don’t work.***

    Now I have damaged my “/etc/emulationstation/es_systems.cfg” file playing around. My Kodi and custom commands returns:
    Unable to create application. EXITING
    Anybody have a clue of what I did wrong?

    • This reply was modified 2 years ago by Profile photo of mirage mirage.
    #94362
    Profile photo of David
    David
    Participant

    Not that this is what happened to you but when I installed Kodi, it made a back up of es_systems.cfg and created an empty one. If I renamed the es_systems.cfg and then installed Kodi, it created a valid es_systems.cfg. If memory serves, installing the Atari 7800 Libretto emulator did the same thing. Perhaps something in my es_systems.cfg did not allow the install to append to it correctly?

    #94363
    Profile photo of buzz
    buzz
    Keymaster

    the #include is not commented out – it should work with the # in front (like a #include statement in C)

    #94365
    Profile photo of
    Anonymous

    Hey, I had this same issue. The way I fixed it was to manually overwrite the retroarch.cfg file in the emulator config directory you are having issues with. Mine was PSX same as the OP.

    All I did was make a new .cfg with retroarch in game then through WinScp deleted the contents of retroarch.cfg (located in /opt/configs/psx) leaving “input_remapping_directory = /opt/retropie/configs/psx/” at the top then copied the output from the saved file into the retroarch.cfg, save, restart EmulationStation and all is fixed… rinse and repeat until satisfied.

    Hope this helps.

    #106085
    Profile photo of andrewchap
    andrewchap
    Participant

    How did you make the retro arch.cfg in game? I am have a heck of a time figuring that out.

    #106086
    Profile photo of herbfargus
    herbfargus
    Moderator

    Select+x is the hotkey to open up the rgui: see this video:

Viewing 15 posts - 1 through 15 (of 15 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar