Retropie 3.0 Beta 4. Retroarch not saving configs on exit?

Home Forums RetroPie Project Controller Configuration in RetroPie Retropie 3.0 Beta 4. Retroarch not saving configs on exit?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 3 voices, and was last updated by Profile photo of crisis6 crisis6 1 year, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #100319
    Profile photo of crisis6
    crisis6
    Participant

    This is a cross post.
    “Retropie 3.0 Beta 4. Why does Retroarch not save controller configurations changes done in RGUI?
    Every time I exit I have to set it all up again. Must the changes be done by command line only or can the changes be made with the RGUI??

    #100320
    Profile photo of herbfargus
    herbfargus
    Moderator

    There is an option to tell it to make sure it saves on exit see this post:

    http://blog.petrockblock.com/forums/topic/cant-access-to-retroarch-settings/#post-99897

    #100321
    Profile photo of crisis6
    crisis6
    Participant

    Thanks.
    How can I get to this through without commands though or is there no other way?
    “config_save_on_exit = true”

    #100322
    Profile photo of herbfargus
    herbfargus
    Moderator

    If I remember correctly I think there is an option in the rgui somewhere as well

    #100323
    Profile photo of herbfargus
    herbfargus
    Moderator
    #100324
    Profile photo of crisis6
    crisis6
    Participant

    While you are changing settings in runtime, they are not saved to disk afterwards on PC by default. If you want RetroArch to automatically write back the config, either set config_save_on_exit = true in config, or enable this under Settings -> Config Save On Exit from within RGUI.

    I make the save on exit to yes but the change does not stay permanent. Upon loading again, the settings are reverted back to default.
    What’s the simplest way to get to:

    “config_save_on_exit = true”

    #100325
    Profile photo of herbfargus
    herbfargus
    Moderator

    Seems there may be one more config to change according to this post:

    http://blog.petrockblock.com/forums/topic/how-to-get-games-to-be-169/#post-100190

    I usually use a program called winscp to edit things, or if you have a keyboard you can plug in you can go into the terminal and edit it with the command sudo nano /opt/retropie/configs/all/retroarch.cfg then locate the lines you need to change and press Ctrl+x to save. Floob has a few videos that outline using the terminal and editing configs.

    This video shows how to save configs. It is about controllers but it should apply to other config changes too.

    #100335
    Profile photo of Floob
    Floob
    Moderator

    Hi crisis6,

    If I am understanding your question correctly, you want to make certain changes in RGUI and for them to be permananent?

    There are a few ways to go about this, but I find the following way the best in order to keep the RetroPie config in place so that you wont encounter future problems, although I am sure there are other ways.

    What I do is
    – Run the game, enter RGUI, then select to save my config
    – This will write out a (new) config file in the directory of the system you were using.
    – I then make my changes in RGUI and save it again, this will create another config file.
    – I compare the two for differences (usually only a couple of lines) then I manually put those lines into either the main retroarch.cfg (if I know I want the change for all systems), or I drop the change into the system specific retroarch.cfg

    But I’m happy to do that for you – all I need is to know which system you are playing when you set the RGUI settings, e.g. SNES. And then when you save the settings – you will see the filename saved shown in yellow text at the bottom of the screen – I need that file.

    I can then tell you a couple of lines to change and it will remember it.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #100399
    Profile photo of crisis6
    crisis6
    Participant

    Thanks for the offer. I did get t sorted it out using the command line and altering the all retroarch config.

    Hopefully I didn’t muck it up it but all is working fine for now.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar