[Retropie 2.x] upgrade from 1.9.x + feedbacks

Home Forums RetroPie Project Everything else related to the RetroPie Project [Retropie 2.x] upgrade from 1.9.x + feedbacks

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of dem1980 dem1980 2 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11687
    Profile photo of nemo93
    nemo93
    Participant

    Hi All,
    I’ve decided to upgrade my Retropie 1.9.1 installation to the latest version and just wanted to share with you my findings as well as some feedbacks.

    * upgrade
    my raspi B is running the latest firmware kernet and all my packages were up to date (apt-get update/upgrade). My memory split is set at 384MB for the GPU. I simply launch the following command:

    $ sudo Retropie-Setup/retropie_setup.sh
    

    Select the “Update Retropie script” item. Wait a bit for the upgrade to complete before exiting the script and launch it one more time. It’s time now to select the first item from the list (Binaries based installation). Time for a coffee break as this step takes some time to complete. At the end of this process, chose the “Update Script binaries” item. I’m not sure if this is needed though. Once all steps are completed reboot…

    * upgrade issues
    1. during the upgrade process I noticed an error while downloading the default “simple” theme from emulationstation’s website. For some reason the script expected a bz2 file or something with a different name whereas the correct file name seems to be http://www.emulationstation.org/downloads/themes/simple_latest.zip
    => after downloading this file and unziping it to /etc/emulationstation/themes/ all went back to normal.

    2. the main configuration file es_systems.cfg is now located at /etc/emulationstation/es_systems.cfg but a default and rather empty file was created under the home directory at ~./emulationstation/es_systems.cfg. The issue is that EmulationStation (ES) will look for the es_systems.cfg file in the following locations and in that order:

    ~./emulationstation/es_systems.cfg
    /etc/emulationstation/es_systems.cfg

    meaning that if the file under ~./emulationstation/ is not valid or empty (which is the case after the upgrade) for some reason an error message is shown at ES startup.
    => I had to copy the file from /etc/emulationstation/es_systems.cfg to ~./emulationstation/es_systems.cfg

    $ cp /etc/emulationstation/es_systems.cfg ~./emulationstation/es_systems.cfg

    Once done I rebooted the raspi and I was able to enjoy the fantastic ES 2.0!! Only 2 issues after such big upgrade is quite impressive and it’s very easy to fix. Good job to petrock and the guys from ES.

    * Feedbacks
    1. How it’s possible to know what exact version of Retropie and ES are currently running? perhaps a simple file located under /etc (/etc/retropie?) with the release version inside would suffice?

    2. screen resolution. Despite I have a 1080p TV I’m using a VGA resolution as recommended in the wiki. I’m wondering if with the new ES version it’s possible to have the pi running a 1080p resolution for the UI and make it switch to a VGA resolution whenever an emulator is launched.

    3. ES related stuff. Scrapper sometimes doesn’t work / Under the various menus you can’t press up to reach quicker the bottom of this menu (you have to hold down the down button) / ES 2 is slower compared to ES1: when you exit a game you have to wait up to 20s prior getting back to the main UI

    hope this helps.
    cheers

    #11701
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Thanks for the feedback!

    Regarding the erroneous theme installation I can say that this was a bug. It was fixed a few minutes ago in the repository at Github.

    #11725
    Profile photo of kitchuk
    kitchuk
    Participant

    I just noticed that the run command directory for sega cd has the older directory style. It’s needs to be the new opt/ directory.

    #11759
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I just noticed that the run command directory for sega cd has the older directory style. It’s needs to be the new opt/ directory.

    Thanks! The RetroPie-Setup Script just got a fix for this.

    #11779
    Profile photo of dem1980
    dem1980
    Participant

    There is not the same problem with (MAME) mame4all ?
    I have a lot of difficulties to run MAME with roms that worked with the 1.10.1 retropie.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar