Retroarch config for HDMI and Composite

Home Forums RetroPie Project Everything else related to the RetroPie Project Retroarch config for HDMI and Composite

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of urichai urichai 3 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5601
    Profile photo of dudumaroja
    dudumaroja
    Participant

    Hello, fist i’d like to thanks this community for retropie

    that said!

    I have a ‘1st world problem’ but i guess other people could benefit from this too!

    i use my raspberry as a semi portable console thanks to retropie

    Retropie in a box

    so i could play my games anywhere! but i cant see to find some how how to set it to keep the games fullscreen on 4:3 CRT tvs using composite and keep the 4:3 aspect ration on widescreen hd tvs using hdmi!

    This is a way to make a script to change to proper retroarch.cfg for the video outup in use?

    i kown that you can get this inforvarion via “tvservice” on raspberry, but i’m to nood to script-it myself!

    My solution for now is to keep a SD for widescreen tvs and one for CRT, but this is just a waste of storage

    can some one helpme?

    #5603
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hi, I think you need to edit config.txt located at /boot/config.txt

    Have a look at the options you can configure here: https://github.com/Evilpaul/RPi-config/blob/master/config.txt

    Specifically sdtv_mode, sdtv_aspect, hdmi_group and hdmi_mode. HDMI will override composite if the Pi detects a HDMI output, but when only composite is connected the Pi should read your specified output settings from config.txt

    If you have found the solution to your problem please mark the topic as resolved.

    #5611
    Profile photo of dudumaroja
    dudumaroja
    Participant

    most crt tv (4:3) can’t adjust the aspect, so i have to set the game to aspect to ‘1’, so it will fill the screen properly, but this settings make the game look streched on hdtv tvs and monitors via hdmi, so i have to set the aspect to 1.33 to get the desired pillar bars, and i think is more of retroarch problem. emulatorstation handle the resolution just fine!

    i really dont see how messing with /boot/config.txt will solve that

    setting the sdtv_aspect to 3 whould generate a 16:9 signal, how a commum crt tv whould treat the image? it will streach the image to fill the screen o it will crop the image(overscan)?

    sadly i do not have a crt tv to test right now.. any thoughts?

    Sorry, i’m very new at this =p

    #5615
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    try setting the HDMI group/mode to a 4:3 in config.txt Also depending on the emulator you could use the Retroarch GUI to adjust the aspect ratio in game

    If you have found the solution to your problem please mark the topic as resolved.

    #5641
    Profile photo of urichai
    urichai
    Participant

    Not sure if I am understanding your question entirely , but here is what I am doing to switch between my 32inch HDMI tv at home and my crappy 19inch composite tv at work.

    In /boot/config.txt find the section below and comment all 3 lines –> HDMI … uncomment all 3 –> Composite

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    #overscan_scale=1

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar