Retro Pad D-Pad down button presses B as well?

Home Forums RetroPie Project Everything else related to the RetroPie Project Retro Pad D-Pad down button presses B as well?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 1 voice, and was last updated by  GreenHoodyGuy 2 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #34632
    Profile photo of prexium01
    prexium01
    Participant

    Hey guys, finally got my Retropie all up and running, finally figured out how to find the CFG file and run the controller config for it, got everything all setup.. starting up a game of Contra III for the SNES… tried to press D-Pad Down, and it will first press B, then press down if I hold it. D-Pad Left is also doing something similar. If I press it, it’ll turn left, and also press Y. I went in and manually edited the .cfg for controller 0, and make sure everything looked kosher.. but I’m very new to linux. Is there something that I somehow missed?

    Any help is MUCH appreciated 🙂

    #34635
    Profile photo of prexium01
    prexium01
    Participant

    Also. I noticed when I used the retroarch configuration command (sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg) when it tells me to configure the B and Y buttons, it phrases it as such..

    Press B (Down) button
    Press Y (left) button

    #35948

    amo

    Hey I have exactly the same problem! When starting e.g. Megaman (NES) it seems to work fine except for the shooting to be on button down instead of B…
    I noticed that changing the retroarch.cfg in folder “all” doesn’t change anything… neither does manual mapping with sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg change anything. The controls with the gamepad stay the same…
    What did we miss out?

    #35976

    amo

    Oh I think I got it. Here’s what you need to do:

    You have to set up hotkeys byadding the following lines to the config file.

    input_enable_hotkey_btn = “8″
    input_exit_emulator_btn = “9″

    Now you can press and hold select and press start to exit an emulator with the controller. If you are in an emulator press and hold select and press F1 (keyboard). Now you can go in settings and input settings and remap the B and Y buttons. You will also need the remap the select button to the select button on the controller (should be button 8 I think). now go back and save the new config. It will be saved to another file than retroarch.cfg.
    Finally you need to exit the emulator and go to the command shell by pressing F4.
    Now go to the config folder:

    cd /opt/retropie/configs/all

    rename the retroarch.cfg to retroarch.cfg.bak2 (backup):

    mv retroarch.cfg retroach.cfg.bak2

    and rename the new config file to retroarch.cfg:

    mv ????.cfg retroarch.cfg

    (I forgot what the new config file was named… something with ???_libretro.cfg)

    I should work…. if not, try to change the mapping like above.

    #37919

    GreenHoodyGuy

    Hey! I tried this but im still having the same problem as above. down still presses b and left still presses y 🙁

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar