Resolving second controller issues

Home Forums RetroPie Project Everything else related to the RetroPie Project Resolving second controller issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of submarinoff submarinoff 2 years, 4 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #84002
    Profile photo of submarinoff
    submarinoff
    Participant

    Hi, all.

    I was having a problem with my player 2 controller on the retropie. I’m running RetroPie 2.3 and using two Acme usb controllers (pretty generic), which are kinda different (i.e. one has the analog inputs, the other doesn’t, etc., basically not the same at all). When I configured my player 2 controller, it didn’t show up in 2-player games, or as in the case of Mario 3, when I entered 2-player mod, both players moved when I used the player 1 controller. However, the player 2 controller was still unresponsive.

    What I did was this:

    I configured my controllers in the following way:

    sudo chown pi /opt/retropie/configs/all/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/all/retroarch.cfg
    

    Then I used nano text editor to change the definitions to match for player 2

    sudo nano /opt/retropie/configs/all/retroarch.cfg

    At the end of the file you will see the configuration for both controllers. You will see two different configurations. You have to change the definitions for one of them (doesn’t matter which one). So, wherever you have stuff like input_player1, etc., you’ll have to change it to input_player2.

    From here, you’ll have to copy all the definitions and put them into the corresponding console’s retroarch.cfg file. For example, for the NES, you have to dump the configuration options into /opt/retropie/configs/nes/retroarch.cfg, so you run

    sudo nano /opt/retropie/configs/nes/retroarch.cfg

    I’m still a linux noob, so I’m not very sure if this will work, but alternatively, you can try

    sudo chown pi /opt/retropie/configs/nes/retroarch.cfg
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/nes/retroarch.cfg
    sudo ./retroarch-joyconfig -j 1 >> /opt/retropie/configs/nes/retroarch.cfg
    

    and then

    sudo nano /opt/retropie/configs/nes/retroarch.cfg

    in order to edit the configurations for player 2. If you want to see the directories for all supported systems, run

    cd /opt/retropie/configs
    ls

    As far as I understand, every system has its own retroarch.cfg file that overrides the global settings, so you can edit them with the abovementioned commands… I think. I tried it and it worked for the NES, haven’t tested it with anything else. Still, it wouldn’t hurt to delete all the configuration options from /all/retroarch.cfg (don’t delete the comments, they’re kinda useful :D)

    I hope I’ve managed to help someone, if not, eh, well… Let me know if it works for someone else. These boards have been very useful and I hope I’ve managed to give back a little.

    • This topic was modified 2 years, 4 months ago by Profile photo of submarinoff submarinoff.
    • This topic was modified 2 years, 4 months ago by Profile photo of submarinoff submarinoff.
    • This topic was modified 2 years, 4 months ago by Profile photo of submarinoff submarinoff.

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar