Really wierd problem with the controller

Home Forums RetroPie Project Everything else related to the RetroPie Project Really wierd problem with the controller

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of bigbert bigbert 2 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6798
    Profile photo of bigbert
    bigbert
    Participant

    I got A really wierd problem that I just can’t solve. I have 2 controllers that was working properly. The problem now is that the number1 controller will stop woking almost everytime I reboot.

    in the /dev/input the js-file keeps switching between js0 and js1 so I have to reconfigure the retroarch.cfg everytime to get it to work again. So that is the problem. Don’t know have to solve this though.

    I have tried having the exakt same configuration for
    input_player1_joypad_index = “0” and
    input_player1_joypad_index = “1”
    That did not work…

    Anyone have any idea how to fix this wierdness?

    I should specify that this only happens in the emulators, not in the menu.

    #6803
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    How are you connecting the controllers to the Pi? Are you using some kind of hub? Have you tried connecting both joysticks in separate USB ports versus through the hub?

    To defeat them is a must and bringing peace to the land is my duty

    #6833
    Profile photo of bigbert
    bigbert
    Participant

    Thanks for the answer!
    No Im not using a hub. Im connecting the two controllers directly to the Pi. I have also tried switching controller ports with the same result.

    #6835
    Profile photo of bigbert
    bigbert
    Participant

    Some new observations:

    if I remove all controllers there is still a js0-file in dev/input.

    If I connect my first usb snes controller, there will be two files, js0 and js1.

    If I connect the snes controller and the xbox controller I will still have 2 files, js0(or js1) and js2. Note. The xbox controller will always work(js2).

    Should I really have a js-file if I disconnect all the controllers? Maybe I could delete the js-file that is left when I have disconnected all the controllers? Or will that break everything?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar