Re-Activate Bluetooth dongle.

Home Forums RetroPie Project Everything else related to the RetroPie Project Re-Activate Bluetooth dongle.

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 3 voices, and was last updated by Profile photo of retchron retchron 2 years, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #92723
    Profile photo of pattaboy
    pattaboy
    Participant

    Hey There,

    I’m almost done with my Retropie project but I’m not so happy how my bluetooth dongle works at the moment.

    How it now works is when I boot up I can wait till the emulationstation splash screen appears and then my bluetooth dongle blinks. when that happens I can succesfully pair my Dualshock 3 controller and I’m ready to play.

    However if I wait a couple seconds more the bluetooth pairing blinking dissappears and then I have to reboot in order to correctly pair it again.

    Can this be done easier?

    Like:
    – When re-inserting the bluetooth dongle the pairing starts again.

    When I pause my game sometimes after 20 minutes the Dualshock3 and the bluetooth dongle completely shuts down to preserve battery power. At that moment I’m stuck at the game. can’t save but I can only reboot to continue playing with my controller.

    I hope this can be done!
    Thanks a lot!

    #92799
    Profile photo of pattaboy
    pattaboy
    Participant

    someone knows this problem or is it just the dongle I use?

    #92802
    Profile photo of tank
    tank
    Participant

    i have the same problem with an logilink bluetooth 2.1 dongle even after installing to 3.0.0 beta (was on 2.6before) i ordered a 4.0 asus one” hopefully the reconnection will work then. i will tell you

    #92805
    Profile photo of retchron
    retchron
    Participant

    I put in a 30s delay on boot to give me more time to pair, see the instructions here http://blog.petrockblock.com/forums/topic/ps3-bluetooth-controller-correct-method-for-retropie-2-3/. (look at comments 84419 and 84681)

    It would be ideal if you could connect anytime though, and I still have issues where sometimes only one controller will connect at a time.

    • This reply was modified 2 years, 1 month ago by Profile photo of retchron retchron.
    #92817
    Profile photo of pattaboy
    pattaboy
    Participant

    I put in a 30s delay on boot to give me more time to pair, see the instructions here http://blog.petrockblock.com/forums/topic/ps3-bluetooth-controller-correct-method-for-retropie-2-3/. (look at comments 84419 and 84681)

    It would be ideal if you could connect anytime though, and I still have issues where sometimes only one controller will connect at a time.

    connecting isn’t really an issue.
    it’s more that when I go out for an hour or something and come back to play again my controller is deactivated which is a good thing but I can’t reactivate it.

    I’m sure it’s possible with some coding/editing or just an option within retropie setup in the future.

    And I’m definitely sure it will help a lot of people!

    #92830
    Profile photo of tank
    tank
    Participant

    you can try adding a few lines to crontab s(started every minute with sleep 5, sleep 10, sleep 15, sleep 20 and so on…
    the command would look like this:
    sudo bluez-test-input connect 65:03:22:B7:04:07

    i’m not sure about performance impact though. i havent tried it yet.

    #92941
    Profile photo of pattaboy
    pattaboy
    Participant

    you can try adding a few lines to crontab s(started every minute with sleep 5, sleep 10, sleep 15, sleep 20 and so on…
    the command would look like this:
    sudo bluez-test-input connect 65:03:22:B7:04:07

    i’m not sure about performance impact though. i havent tried it yet.

    Just found out how to set scan all the time so that when your controller times out then you can repair it.

    just go to

    sudo nano /etc/rc.local

    add the following 2 lines right before the “exit 0″ line:

    hciconfig device up
    hciconfig enable pscan

    This should do the trick

    #92943
    Profile photo of tank
    tank
    Participant

    so without these lines nobody was able to RE-connect their gamepads before?!

    it would be very nice if that would work!! thank you 🙂

    edit: yes, it’s working now… so everyone just deals with this issue or was everyone keeping this commands a secrets?or arent they neccessary with all dongles?

    • This reply was modified 2 years, 1 month ago by Profile photo of tank tank.
    #92963
    Profile photo of retchron
    retchron
    Participant

    I get an error saying “Warning: unknown command – “enable”

    /etc/rc.local: 26: /etc/rc.local: pscan: not found”

    Sent from my iPhone using Tapatalk

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar