Raspberry Pi 3 freezes?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 9 voices, and was last updated by Profile photo of nonorius nonorius 12 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #119654
    Profile photo of elgur85
    elgur85
    Participant

    Hello!

    I’ve had my Pi3 for about a week ago, and it freezes a lot.
    As soon as I just let it be online, without playing, it freezes.

    Can’t ssh it or using connected keyboards or controllers.

    Have anyone else experienced this?

    #119662
    Profile photo of auswear
    auswear
    Participant

    Can you SSH in and see what temp it’s running at?

    I had the same issue with mine but then realised I was using my old config.txt from my Pi 2 which had temp_limit=75

    The Pi 3 runs much hotter and after a couple of hours use mine sits around 85 degrees

    #119751
    Profile photo of elgur85
    elgur85
    Participant

    Nope, I can’t access it through SSH. I’ve seen it around 55-60, so no high temperature.
    Using a newly downloaded Retropie image for the RPi3, so the config.txt is not for my RPi2.

    #120113
    Profile photo of gamesfan
    gamesfan
    Participant

    Do you have any heatsinks or fans? I use them with my RPI2 as it would freeze in some long gaming sessions. Once I put on the heatsinks and fans the issues went away.

    Also the RPI3 requires a beefier powersupply at 2.5amps , maybe your PS isnt giving it enough current and that is causing the lockups.

    #120252
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    I can almost guarantee it’s your power supply. As Gamesfan says, you need 2.5amps.

    #120772
    Profile photo of belowstupid
    belowstupid
    Participant

    It’s not the power supply. I have the same problem and my power supply is 3.5amp with heatsinks and fan.

    #120868
    Profile photo of elgur85
    elgur85
    Participant

    It shouldn’t be the powersupply since I use the official powersupply…

    #120889
    Profile photo of pohlinger31
    pohlinger31
    Participant

    Mine has been freezing as well – seems to be in certain games, especially a few PS1 games. Not sure what the issue is… I also had it freeze in the retropie setup menu, which was very odd.

    #120894
    Profile photo of elgur85
    elgur85
    Participant

    I don’t know if the issue is in Retropie (the image) or the Pi itself.
    I have other strang issues, like drops in SSH connections, and problems to reboot the Pi, it sais that it’s going to reboot, but nothing happens.

    #120926
    Profile photo of pi-guy
    pi-guy
    Participant

    I’m having the same issue with ssh, but I’m using wifi and I read somewhere that the built-in wifi driver is having some issues on some OS flavors…maybe this one too. Are you using wifi and if so are you using the onboard wifi or a usb stick?

    #121117
    Profile photo of robboman
    robboman
    Participant

    I’ve been running my RP 3 for days on end, no freezes here.

    #121225
    Profile photo of pi-guy
    pi-guy
    Participant

    Have your tried the built-in wifi? If so, within 10min I can almost guarantee you’ll lose a ping or more especially if your CPU is busy. Though I did find that having too many devices plugged into the usb port exacerbates the issue, especially if you use a 10′ long usb extension cable like I do. Probably a power thing, my guess is if under med-high CPU load and a few peripherals (w/o external power) are plugged in it starts shutting down power to the wifi before anything else.

    I’m working on finding or acquiring a powered usb hub (which I know is kind-of the golden rule with Pi’s) to see if that helps things along.

    #121700
    Profile photo of nonorius
    nonorius
    Participant

    Hello,

    I have the same issue: http://blog.petrockblock.com/forums/topic/regular-freezes-with-raspberry-23/

    Sorry to trust several topics with this but I try to find a way to fix this.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar