Raspberry-pi 2 compatibility

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 251 replies, has 82 voices, and was last updated by Profile photo of buzz buzz 2 years, 2 months ago.

Viewing 35 posts - 71 through 105 (of 252 total)
  • Author
    Posts
  • #86555
    Profile photo of buzz
    buzz
    Keymaster

    Those of you lucky enough to have a rpi2, who want to build from source (either everything or individual emulators to test performance), you can do

    
    sudo MAKEFLAGS="-j4" ./retropie_setup.sh
    

    which will use 4 workers for building – so your additional cores will be utilised.

    if you would like to see if building for armv7 gives better performance, you could do something like

    
    sudo CFLAGS="-O2 -mfpu=neon -march=armv7-a -mfloat-abi=hard" MAKEFLAGS="-j4" ./retropie_setup.sh
    

    instead of retropie_setup.sh you can also use retropie_packages.sh to build with the commandline interface.

    note that some emulator build scripts/makefiles may override your cflags. some may also not build correctly when using -j4.

    I build on an emulated arm chroot, with a cross compiler on a fast pc, using -j8. The emulated chroot does the preprocessing, and the cross compiler does the compiling. With such a set up it is possible to build everything in an hour or so.

    • This reply was modified 2 years, 2 months ago by Profile photo of buzz buzz.
    • This reply was modified 2 years, 2 months ago by Profile photo of buzz buzz.

    #86558
    Profile photo of chito
    chito
    Participant

    Tested Advmame. Yeah no visible improvement. Im guessing those guys need to recompile their binaries. mame4all no visible improvement (worked pretty well in the b+)

    all other RetroArch ems that i have seem to be good.
    tested a few games for master system, megadrive, gba, snes

    Just need updated binaries for the mame emulators. Would it be possible to run the current original mame now?

    #86559
    Profile photo of chito
    chito
    Participant

    Hey Buzz
    what build do you make? what optimisations did you compile for?

    #86560
    Profile photo of buzz
    buzz
    Keymaster

    not sure what you are asking sorry. that image has no emulators optimised for the armv7 – you can test compiling yourself though.

    • This reply was modified 2 years, 2 months ago by Profile photo of buzz buzz.
    #86562
    Profile photo of chito
    chito
    Participant

    Sorry when you said updated binaries I thought you meant for the new core

    #86563
    Profile photo of buzz
    buzz
    Keymaster

    no, although I’m building some right now, and you can see if you get any performance difference when they are complete. but if you want to test a single emulator you can build with the instructions given earlier.

    #86564
    Profile photo of chito
    chito
    Participant

    Well the console ones seemed greate already on the b+ just smoother now.
    once the new V7 binaries are done, will it be a simple retropie script then binary update? or will i need to setup a new image?

    What can be done about the mame binaries?
    im assuming that when u say build ur talking about retroarch emulators only. Not 3rd party ones

    #86577
    Profile photo of silkworm
    silkworm
    Participant

    It took most of last night to update the Pi as it kept failing to fetch the packages, I guess their servers were being hammered.

    Everything is running a lot slicker on the Pi2. This morning I popped Star Fox on. As has already been reported the difference is night and day, it’s completely playable now. It’s not “perfect”, you get the odd sound glitch here and there, and a bit of slowdown when a lot is going on, but that’s nit-picking (I remember from my childhood that the SNES itself used to do this on Star Fox).

    Currently I have done nothing more than run “sudo apt-get update && sudo apt-get” on a V2.3 Retropie image. No overclocking, memory changes, recompiling, anything. Just wanted to say that at this point, even without all of the multi-core binaries and other goodies to come, for me the upgrade is already worth it.

    If there are any games you want me to test, let me know.

    #86578
    Profile photo of robertybob
    robertybob
    Participant

    If there are any games you want me to test, let me know.

    I’m very interested in the reported improvements to the N64 games. I presume it’s not possible to show on screen the FPS rate, so I wondered whether you could see whether Perfect Dark, Super Smash Bros and Mario Party 2 are playable. If so, does it appear to be slower than it was running on a ‘normal’ PC ?

    #86579
    Profile photo of david
    david
    Participant

    I tried RP2 and RetroPi yesterday with various results. Boot was easily fixed. Running emulationstation interface no issues. Starting all doom/quake games from ports worked very good. But one thing i had a major problem with is almost all other emulators. They all seem to run with sound, but screen is black. Megadrive emulator dgen, snes9x etc. even dosbox. Changing the resolution (pressing ‘x’) before emulator started didn’t change anything.

    However they did show graphics if i started them from within Xwindow.

    I compiled a small SDL example and that gave the exact same results. Black screen.
    Any ideas?

    #86580
    Profile photo of buzz
    buzz
    Keymaster

    I believe it’s all related to the new kernel/firmware update – I’m going to test by downgrading the kernel on my pi and see.

    Hopefully this will be sorted soon, but I’ll get back when I have further info. enabling dispmanx for those emulators may help (in supplementary config)

    #86581
    Profile photo of morias
    morias
    Participant

    I have updated my Retropie and run it on a Pi 2. On a quick test, PS1 games are a lot faster, SNES about the same, however Megadrive is very slow with choppy sound. They are all running on Retroarch.

    #86583
    Profile photo of untakatapuntaka
    untakatapuntaka
    Participant

    I have updated my Retropie and run it on a Pi 2. On a quick test, PS1 games are a lot faster, SNES about the same, however Megadrive is very slow with choppy sound. They are all running on Retroarch.

    Nice to hear that =)
    Is PSX emulation now smooth or “just” “better” ?

    #86584
    Profile photo of Roo
    Roo
    Participant

    How is Mortal Kombat in MAME4ALL? On a B+ it is playable but the sound glitches out.

    #86585
    Profile photo of buzz
    buzz
    Keymaster

    I have opened a ticket here

    https://github.com/raspberrypi/firmware/issues/354

    hopefully something comes of it. Looks like it all broke at the 3.18.4 update – the previous 3.18 kernel was fine. so either something in the kernel, or a configuration change or something else (there are firmware changes too). Impossible to know as there are only binary changes here and no sources to reference.

    • This reply was modified 2 years, 2 months ago by Profile photo of buzz buzz.
    #86586
    Profile photo of buzz
    buzz
    Keymaster

    those who don’t have a pi 2 – can run

    
    rpi-update 9ae54e3
    

    to downgrade their system to a point that should work. This won’t work on the pi2 since it is before support was added.

    • This reply was modified 2 years, 2 months ago by Profile photo of buzz buzz.
    #86589
    Profile photo of markyboyuk
    markyboyuk
    Participant

    buzz your new image (https://docs.google.com/uc?id=0B_knGioK16E6c0d4MDZCRUlqclU&export=download) boots fine on my pi 2. One issue I have noticed since using the pi 2 is that myy joypad/adaptor is no longer detected. If i place the SD card back into my pi 1 the adaptor is detected as “Dual PSX USB Adaptor” and it works fine with the pi 1. Any ideas why my USB game adaptor is not detected by the pi 2 but the same adaptor works fine on the pi 1? (using the same microSD card).

    Thanks

    #86590
    Profile photo of buzz
    buzz
    Keymaster

    I don’t sorry. what does dmesg say when you plug it into the pi2 ? (Maybe should start a new thread for this)

    #86591
    Profile photo of markyboyuk
    markyboyuk
    Participant

    I don’t sorry. what does dmesg say when you plug it into the pi2 ? (Maybe should start a new thread for this)

    it says

    [ 34.683146] usb 1-1.2: USB disconnect, device number 4
    [ 38.759163] usb 1-1.3: new low-speed USB device number 6 using dwc_otg
    [ 38.871689] usb 1-1.3: New USB device found, idVendor=0b43, idProduct=0003
    [ 38.871719] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber =0
    [ 38.871738] usb 1-1.3: Product: Dual PSX-USB Adaptor
    [ 38.871756] usb 1-1.3: Manufacturer: Dual PSX-USB Adaptor
    [ 38.889315] usbhid 1-1.3:1.0: can’t add hid device: -32
    [ 38.889402] usbhid: probe of 1-1.3:1.0 failed with error -32
    [ 46.204728] usb 1-1.3: USB disconnect, device number 6
    [ 48.489179] usb 1-1.2: new low-speed USB device number 7 using dwc_otg
    [ 48.602585] usb 1-1.2: New USB device found, idVendor=0b43, idProduct=0003
    [ 48.602609] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber =0
    [ 48.602627] usb 1-1.2: Product: Dual PSX-USB Adaptor
    [ 48.602644] usb 1-1.2: Manufacturer: Dual PSX-USB Adaptor
    [ 48.619463] usbhid 1-1.2:1.0: can’t add hid device: -32
    [ 48.619537] usbhid: probe of 1-1.2:1.0 failed with error -32

    #86592
    Profile photo of buzz
    buzz
    Keymaster

    something isn’t working then. no idea if kernel issue or firmware though or something else. try it with the latest raspbian image perhaps to check.

    #86593
    Profile photo of morias
    morias
    Participant

    Nice to hear that =) Is PSX emulation now smooth or “just” “better” ?

    I didn’t try it for long, but playing Gran Turismo it felt like it was 20 years ago when I played in on my PS1. So I would say it was “smooth”.

    #86596
    Profile photo of r3dstar
    r3dstar
    Participant

    I’ve found GoldenEye to be running around 25-50% under what it should be, depending on how many polys are on screen.
    Smash Bros was a bit slow in a 1 on 1 with Mario and Link, but against 3 Yoshis it was really, really slow.
    Mario Kart 64 is the best so far.

    As others have said, StarFox on the SNES is running like a dream.

    #86597
    Profile photo of brooksyx
    brooksyx
    Participant

    This is awesome!! Just ordered one for a portable project I am working on (using a broken game gear as a shell, adding extra buttons and 4.3″ screen). Will probably upgrade the model b in my snes build in a few months as well. Hopefully it won take to long to get here, currently on back order.

    #86600
    Profile photo of robertybob
    robertybob
    Participant

    I’ve found GoldenEye to be running around 25-50% under what it should be, depending on how many polys are on screen. Smash Bros was a bit slow in a 1 on 1 with Mario and Link, but against 3 Yoshis it was really, really slow. Mario Kart 64 is the best so far.
    As others have said, StarFox on the SNES is running like a dream.

    Ah that’s disappointing to hear. Hopefully it’s the software that’s the problem and someone somewhere will get it up to a better speed on the Pi.

    #86601
    Profile photo of brooksyx
    brooksyx
    Participant

    <div class=”d4p-bbt-quote-title”>r3dstar wrote:</div>I’ve found GoldenEye to be running around 25-50% under what it should be, depending on how many polys are on screen. Smash Bros was a bit slow in a 1 on 1 with Mario and Link, but against 3 Yoshis it was really, really slow. Mario Kart 64 is the best so far. As others have said, StarFox on the SNES is running like a dream.

    Ah that’s disappointing to hear. Hopefully it’s the software that’s the problem and someone somewhere will get it up to a better speed on the Pi.

    I’m sure that this updated raspberry pi will increase interest in working on the N64 emulator and other emulators. I feel like part of the problem is people lost interest due to the lack hardware power. It will also probably help that the new version is based on Arm7, which a lot of android phones use this architecture. Phones with similar specs run a lot of N64 games just fine.

    • This reply was modified 2 years, 2 months ago by Profile photo of brooksyx brooksyx.
    #86603
    Profile photo of pmurch
    pmurch
    Participant

    Out of curiosity, when more things are rebuilt to take advantage of multi core, will we be able to use the update binary option in retropie setup? Or will we have to re-image?

    #86604
    Profile photo of buzz
    buzz
    Keymaster

    you can’t just rebuild something to take advantage of multiple cores automatically – it has to be written in a way to support it. Most emulators are single threaded by design. if they have more than one thread, its likely just maybe sound or having rendering split out, so you don’t get 2x performance exactly. Stuff that benefit from multiple cores are applications / compiling / video decoding (where a decoder can decode future frames on multiple cores – ffmpeg / xbmc supports this)), multitasking/desktop apps etc,

    I will provide some binaries compiled for the cortex-a8 for testing – they may offer better performance. Some can be rebuilt out of the box, but some like mame4all need the makefile adjusted since its hardcoded for armv6.

    #86606
    Profile photo of pmurch
    pmurch
    Participant

    you can’t just rebuild something to take advantage of multiple cores automatically – it has to be written in a way to support it. Most emulators are single threaded by design. if they have more than one thread, its likely just maybe sound or having rendering split out, so you don’t get 2x performance exactly. Stuff that benefit from multiple cores are applications / compiling / video decoding (where a decoder can decode future frames on multiple cores – ffmpeg / xbmc supports this)), multitasking/desktop apps etc,
    I will provide some binaries compiled for the cortex-a8 for testing – they may offer better performance. Some can be rebuilt out of the box, but some like mame4all need the makefile adjusted since its hardcoded for armv6.

    No worries. I get that. I’m a software developer 🙂
    I am just envisioning the end of audio skipping if the emus have been written with the ability to split audio off to its own thread.

    Thanks!

    #86609
    Profile photo of buzz
    buzz
    Keymaster

    Sorry about that.

    I don’t actually know off hand any that do. if some do have two threads say audio/video, it doesn’t necessarily mean that the audio emulation would be done in the audio thread as you will know – maybe just the sending the buffer to the hardware etc. I read that retropie has some software filters than work with multicore which might be of use.

    The biggest speedup is going to just be the fact that each core is quicker – and perhaps something will be gained from building for the armv7, and maybe some speedup if/when we move to gcc 4.8 from 4.7 as our default compiler too.

    anything that has armv7 assembler in is going to work nicely too. I believe ffmpeg has plenty of arm optimisations.

    #86612
    Profile photo of malla
    malla
    Participant

    If there are any games you want me to test, let me know.

    What about Yoshi’s Island and Super Mariokart on SNES? Do they work properly when you don’t overclock your RP2?

    #86642
    Profile photo of moran1804
    moran1804
    Participant

    Wow Guys,

    So i got my RPI2 yesterday i used the base image freshly compiled by *Buzz* Massive Thanks By the way.

    What can i say i built a bartop arcade machine with my Pi B+ and had similar problems to everyone my sound was an issue on some games i also got slow down on games like street fighter and MK but worst of all NBA jam on mame as that game is an absolute classic.

    now after using the base image and configuring it with all the personal changes i made to my previous system and copying across all personal files and scripts.

    i can report it runs beuitifully, MK, Street Fighter 2 and NBA Jam run in MAME Flawlessly no slowdown and smooth. i also gave configuring N64 a go as i gave up on my B+ as it was just too slow and the fact my B+ struggled with the sound on Tetris+DR Mario there was no way it would run N64 half decent,

    well using Mupen64Plus i now have Mario Kart running well there is the odd glicth with things like shells when you first press the fire button they will appear as a black square for a split second but it is ultimately very very playable.

    i only have one question for the experts on here for some reason if i play snes and mame games exit them and play a 64 game it changes the resolution and mario kart appears in a small screen in the bottom left hand corner of my screen and for the life of me i cant work out what the other emulators change because if so i could update the .sh to put it back before loading the n64 game.

    if you play alot id deffo upgrade to the PI2 im fairly good with linux and shell scripting and took me a few hours to migrate worth every second.

    Cheers
    Mike

    Attachments:
    #86645
    Profile photo of juicebag
    juicebag
    Participant

    Hi Mike.

    Great to hear, that everything works so well. 🙂 And that’s a really nice machine you built there btw. 😉
    Do you have this “bug” with the n64 only if you use the snes or mame emulator or also when using other emulators? And do you have any problems when starting mupen64 first?

    Btw I got 3 questions msyself for you guys. 🙂
    1. Does the n64 emulator start right now by itself? I didn’t get on the problem since half a year but I remember that you weren’t able to start any games with it.
    2. I use the Retropie on a raspberry B+ which is overclocked to 1000 Mhz. A bis concern for me was that one of my fav games “Mega Man 2” just ran with reduced with the RetroArch emulator. The gameplay and also the sound were a bit slower than in the original which bothered me so much, that I didn’t really want to play it. 🙁
    Did anybody else expirienced this issue? And can you tell me that “Mega Man 2” now runs smoothly in it’s native speed on the pi 2? 🙂
    3. Is the V2.4.2 Image in the download section already compiled for the pi2?

    Thanks!

    • This reply was modified 2 years, 2 months ago by Profile photo of juicebag juicebag.
    #86647
    Profile photo of
    Anonymous

    Hello Community,

    thakns for all the help here. Short question , how do i get my Mame Games to work , i got a Mame Pack with all the games but they wont work on the RPI (Modell B+). I assume i got the wrong files for it , is there any way to extract the files from my original catriges or where do you get the games from and which one is the best Emulator to play the Mame Games on the RPI ( i think im gonna switch to RPI 2 soon 🙂 )
    Can anyone say which are the best Emulators on the RPI for the following systems?
    Mame
    ScummVM
    SNES
    N64
    Mega Drive

    Thank you very much and have a nice day 🙂

    #86660
    Profile photo of lightthief
    lightthief
    Participant

    Where are people getting their rpi2s from?
    My order at Newark is just sitting there so far.

    #86661
    Profile photo of tinblue
    tinblue
    Participant

    Where are people getting their rpi2s from? My order at Newark is just sitting there so far.

    http://www.farnell.com/

Viewing 35 posts - 71 through 105 (of 252 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar