PSX emulator bios path

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.


This topic contains 16 replies, has 9 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years, 2 months ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
  • #3151
    Profile photo of kennyhun

    Hi everyone!

    I made a lot of search about my issue but I could not find any good response. My question is easy. In raspberry, where is the BIOSs path for PSX where I can copy my BIOS files? Currently the ‘native’ BIOS is very weak and it is misleading that I start a PSX game and it says in yellow ‘No BIOS found’.

    Thank you!

    Profile photo of huettmaster

    i have the same problem…the paths i found in other forums don´t work…

    Profile photo of kennyhun

    The native bios seems to be lack of quality, some of the psx games have graphical glitches, wrong colors etc and low fps (dunno if bios version fault tough)

    Profile photo of motorhead

    I have the same problem too, but the first time that I tried to run a psx game it worked! told that it had no bios but the game worked… Now I can’t play any psx game…

    Profile photo of motorhead


    I got it! I have psx games working! I think I had two different issues:

    First of all, You can choose a system directory editing this file:


    I choosed this one:


    And I put here my pcsx1001.bin file. Im trying to do the same with neogeo.bin for MAME…

    Next I saw that the error (The screen with the errors is ultra fast, but making a video with the phone will work) was that my must be renamed to, and thats all!!

    I hope this will help someone.

    Profile photo of FreezX

    Motorhead, I think you have the right idea about the systemdirectory, but I’m not sure about renaming the file. Mine still looks for exclusively. Also, did you mean retro instead of reto? Just curious, still trying to get this to work 110%.

    Profile photo of petrockblog

    Great work here! If you have found a working solution it would be great if you could add these information to

    Profile photo of motorhead

    Hi! Sorry, it was a mistake, it’s you’re right. The error given from Pcsx_rearmed was in a 1.8, and that solved the issue. Few days ago I reinstalled a fresh 1.9.1 image and there was no signal from this error… there is no need to rename now.

    Profile photo of FreezX

    Okay, awesome, thanks for helping to clear that up. Also, I got mine to work with a specified bios on the most recent version. Here’s a write-up:

    Create the directory to store BIOS files:


    Make sure you copy your bios files into that directory with no capitalization in any part of the name or file extension.

    Next, edit the file:


    and add the line:

    system_directory = /home/pi/RetroPie/BIOS

    Thank should do it. If anything doesn’t work with that solution, holler down below.

    Profile photo of FreezX

    petrockblog: Thanks for the suggestion, wiki updated!


    david g.

    i got retropie 2.3 but the part to save system_directory = /home/pi/RetroPie/BIOS line dont’ work and that makes me left on spot what should i do? a response whould be awesome. thanks david.

    Profile photo of muffy

    i have the same problem with version 2.3!
    i’m not able to get the BIOS for psx to work.

    does anybody have a solution ?


    Edri Espinoza

    Logré de que ya no aparezca el mensaje de “no BIOS found, bugs expected”, pero no noto alguna mejoría, así que no estoy seguro de que sirva, pero lo que yo hice fue poner una Bios en la ruta /opt/retropie/emulatorcores/pcsx_rearmed/ con el nombre “scph1001.bin” y edité el retroarch.cfg que está en /opt/retropie/config/all/ y hay una línea que dice “system_config =” y agregué la dirección de dónde estaba la bios. Si, uso la versión 2.3. También necesito ayuda. Con Dino Crisis ocurre un error visual en el menú de objetos y eso, y también en el menú de PlayStation. Se ven muchas líneas negras en la pantalla, dificultando la lectura, si alguien me puede ayudar con esto se lo agradecería mucho.

    Profile photo of crudster

    Figured it out, in newest retropie, they go into


    Not in the subfolders of that folder.

    So in the above folder you should have all your SCPH????.bin files.

    Profile photo of fistwielder

    Has anyone successfully run PSX games with the new Retropie 2.4.1 beta image? Mine always crash regardless of which BIOS file I use. All PSX game start up just fine but crash within a minute.

    Profile photo of buzz

    I have – although I found compatibility to be somewhat poor. I did find some games that worked though. Hopefully compatibility will improve with updates but Crash_Bandicoot worked for example.

    Profile photo of herbfargus

    I had the same problem, all of my psx games were working just fine in 2.3 but once I upgraded to 2.4.2 they crash halfway through- I have the proper BIOS and everything. Hopefully someone comes up with a solution for this bug.

Viewing 17 posts - 1 through 17 (of 17 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar