Ps3 sixaxis button config help

Home Forums RetroPie Project Everything else related to the RetroPie Project Ps3 sixaxis button config help

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of cliffbrowning84 cliffbrowning84 2 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #83235
    Profile photo of cliffbrowning84
    cliffbrowning84
    Participant

    Maybe I’m wrong but it seems that the emulationstation, namely the roms, are picking up on my ps3 controllers motions which is creating pure havoc and making it impossible to play the games and real tough just to configure the buttons. It could just be some loose sticks but will the system pick up on the ps3 controllers motions? If so how do I disable this? Btw this appears to only be when running through bluetooth. It seems fine when directly wired to the pi

    #83255
    Profile photo of fortinbra
    fortinbra
    Participant

    What I did to work around this was to place the remote on a table when setting up the controls, and I was careful not to nudge the controller as I pressed the buttons. If do your button setup manually, you won’t need this.

    #83273
    Profile photo of cliffbrowning84
    cliffbrowning84
    Participant

    I firgured as much out but once I got playing a few games to test it, it seemed to pickup on my controller angles. I copy pasted someones work to configure it manually it stopped but I had other issues. Since I have been in and out of all the files tweaking everything I decided to format the sd card and reinstall the os. I havent put sixaxis back on yet. I would still like to know how to get around the motion sensor, preferably just turn it off, in case this becomes an issue later.

    #83276
    Profile photo of dudleydes
    dudleydes
    Participant

    If it is only with Bluetooth you are having problems then the accelerometers may be enabled in your sixad profile (assuming that you are using sixad to pair your controller). You can check with the following command

    sudo nano /var/lib/sixad/profiles/default
    For the accelerometers to be disabled, the profile should look as below with the last four parameters (enable_accel, enable_accon, enable_speed, enable_pos) set to 0.

    enable_leds 1
    enable_joystick 1
    enable_input 0
    enable_remote 0
    enable_rumble 1
    enable_timeout 0
    led_n_auto 1
    led_n_number 1
    led_anim 1
    enable_buttons 1
    enable_sbuttons 1
    enable_axis 1
    enable_accel 0
    enable_accon 0
    enable_speed 0
    enable_pos 0
    #83284
    Profile photo of cliffbrowning84
    cliffbrowning84
    Participant

    Thanks dudleydes. I may be a day or so before I get to that but it looks promising. As a side note, I have a problem when I pair to my bt then obviously it wont pair with the ps3. I tinkered with this for about 10 minutes before reinstalling retropie but I just added my sixaxis and connected back to the pi and im watching netflix on the ps3. My ps3 is on an hour deactivity timer and now I cant do anything about it. I got it to reconnect the other day by plugging the controller into the ps3 and hitting the ps button but I could not get it to consistently work with only the pi after that. It kept wanting to turn on the ps3. This is mostly due to my lack of understanding the processes im sure. Im also sure I can type something in to reconnect it to the pi but Im building this for a friend for xmas and he isnt computer savy, especially linux. Is there an easy consistent way to switch back and forth between the two devices using maybe just the cord and rebooting? I understand not asking two questions on a post but thought I would try. Im happy with just the answer to the original question.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar