PS3 Controller Config Being Overwritten

Home Forums RetroPie Project Controller Configuration in RetroPie PS3 Controller Config Being Overwritten

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of SomeCoolName SomeCoolName 12 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #121150
    Profile photo of SomeCoolName
    SomeCoolName
    Participant

    Trying to set up a generic PS3 Bluetooth controller I picked up an Amazon, and having a weird issue. I am running a Pi 2 with Retropie 3.5, because the controller would not re-pair properly after rebooting the Pi on Retropie 3.6. I installed the controller with the Gaisa clone support, and it appears to be paring properly and working well.

    I am trying to manually edit the config file for the PS3 controller to set up hotkeys. I am able to get everything set up properly and it tests fine, but when I reboot the Pi the hotkeys stop working. If I go back into the config file, all of the changes I make are gone. Its as if the file is being completely overwritten.

    I am not sure if its related or not, but when I reboot the pi and re-pair the controller emulation station isn’t recognizing anything is connected until I hit some buttons on the controller.

    This controller was working fine on a previous installation of Retropie 3.4 that I had upgraded to 3.5. I am attempting to re-build the image after the SD card had become corrupt on me.

    Anyone have any ideas what could be happening here?

    #121633
    Profile photo of SomeCoolName
    SomeCoolName
    Participant

    For anyone else having this issue, I was able to solve it. It turns out that whenever the controller paired while emulation station was loaded it was moving my PS3 controller config to a cfg.bak file and generating a new config file. I was unable to do anything about this.

    In the end, I used RGUI in the Retropie menu to set up the hotkeys for the controller in the actual retroarch.cfg. After saving the config file, I removed retroarch.cfg and renamed the file generated by RGUI to retroarch.cfg so that it became the config. Now when the new config file is generated for my controller, the hotkeys still function because they are hard coded into retroarch.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar