Problems with keyboard shortcuts in emulators

Home Forums RetroPie Project Everything else related to the RetroPie Project Problems with keyboard shortcuts in emulators

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of bravetoaster bravetoaster 2 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #89630
    Profile photo of bravetoaster
    bravetoaster
    Participant

    Hi,

    I’ve set up RetroPie on a new Raspberry Pi 2B and am using a PS3 controller connected through Bluetooth as well as a Logitech wireless keyboard with touchpad.

    However, none of the keyboard shortcuts work in the emulators. For example F1 doesn’t open the settings, N/M don’t switch through the shaders and the like.
    The PS3 controller works fine (which is really awesome, by the way!).

    I can quit the emulator with Start+Select on my controller, and I can access the menu with Select+Triangle, but neither is possible with the keyboard.
    Also, when I’m in the emulator menu, I can use the keyboard with the keys listed, but I’m completely stuck when I hit Triangle and open the “Search” box – no keyboard input is accepted an no combination of controller buttons seems to do anything. At that point, I can only cut the power or SSH into the Raspberry Pi and run “sudo reboot”.

    I have attached the following files:
    – /opt/retropie/configs/all/retroarch.cfg (no keyboard bindings are defined in any of the emulator specific config files)
    – /opt/retropie/emulators/retroarch/configs/PS3ControllerBT.cfg (I think this is the right file, but not sure – there’s also Sony_PLAYSTATION(R)3_Controller.cfg and SonyComputerEntertainmentWirelessController.cfg in that directory)

    It would be great if I could get my keyboard to work in the emulators – I’d really appreciate the shortcuts for save/load and settings and would prefer to have them there instead of on the controller.

    Thanks!

    • This topic was modified 2 years, 1 month ago by Profile photo of bravetoaster bravetoaster.

    #89634
    Profile photo of Floob
    Floob
    Moderator

    Hold down “select” on the joypad, then try F1, or n, m etc…

    Its because you have set an enable hotkey function.
    input_enable_hotkey_btn = “0”

    Details are here:

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #89635
    Profile photo of bravetoaster
    bravetoaster
    Participant

    Ah, yes – that’s it. Thank you!

    I also noticed that in my retroarch.cfg at the very bottom there was the line
    input_enable_hotkey = nul

    I changed that to tab and now I can do tab+F1 etc. and it works like a charm. Cool!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar