Problems configuring a controller in RetroArch

Home Forums RetroPie Project Everything else related to the RetroPie Project Problems configuring a controller in RetroArch

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 2 voices, and was last updated by Profile photo of tafazzi87 tafazzi87 2 years, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11999
    Profile photo of crixd
    crixd
    Participant

    Just got my Pi home and installed RetroPie via the SD Card method.

    I have followed this guide: http://zsprawl.com/iOS/2014/06/playing-old-skool-games-on-a-raspberry-pi/

    It was going smooth, until I had to configure my gamepad.

    The problem arises with this codeline:

    cd ~/RetroPie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig -j 1 >> ~/RetroPie/configs/all/retroarch.cfg

    I know that the new release has moved the config into /opt, but I cannot use the -j 1 prefix, and I can only use this line ./retroarch-joyconfig but not the rest.

    Does anybody know how to fix this? As I am quite a linux newbie and got no clue.

    Thanks! πŸ™‚

    #12001
    Profile photo of tafazzi87
    tafazzi87
    Participant

    i’ve use ./retroarch-joyconfig without option -j and it works…sincerely i don’t know what -j option do

    #12003
    Profile photo of crixd
    crixd
    Participant

    I have configured the gamepad using these lines:

    cd /opt/retropie/emulators/RetroArch/installdir/bin
    Then I used the ./retroarch-joyconfig and mapped the controller.

    After that I am stuck, I can find the .cfg but I do not know what to do.

    I tried skipping the step and tried to play a game, but it still does not work – The gamepad works fine in EmulationStation btw.

    #12005
    Profile photo of tafazzi87
    tafazzi87
    Participant

    you have to do

    
    cd /opt/retropie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig >> /opt/retropie/configs/all/retroarch.cfg
    

    after you’ve set your controller…

    #12012
    Profile photo of crixd
    crixd
    Participant

    Stupid me.. I thought I had to split the line up.

    It did the trick – Thanks! πŸ™‚

    #12013
    Profile photo of crixd
    crixd
    Participant

    How can I edit the .cfg file?

    I tried to locate it on WinSCP, but it seems it is hidden?

    #12022
    Profile photo of tafazzi87
    tafazzi87
    Participant

    from terminal

    
    sudo nano /opt/retropie/configs/all/retroarch.cfg
    

    after you have modify, for save press Ctrl+O (O not zero πŸ˜€ ) and press Enter, to exit from editor press Ctrl+X

    #12031
    Profile photo of crixd
    crixd
    Participant

    You Sir, are a gentleman and a scholar!

    Thanks! πŸ™‚

    #12034
    Profile photo of tafazzi87
    tafazzi87
    Participant

    thanks, it’s a pleasure πŸ˜‰

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar