Problems compiling from source with script

Home Forums RetroPie Project Everything else related to the RetroPie Project Problems compiling from source with script

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of petrockblog petrockblog 3 years, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1873
    Profile photo of Mike Ellery
    Mike Ellery
    Participant

    I’m getting errors compiling retroarch and dgen with the script

    retroarch complains about missing <libavutil/channel_layout.h> It’s not in my /usr/include and doesn’t seem to be part of the libavutil-dev package.

    When I try to install everything with the precompiled binaries, after generating the es_systems.cfg, only apple is detected as having roms. es_log.txt has this

    lvl2:   Starting SDL...
    lvl2:   Creating surface...
    lvl2:   Resolution: 720x480...
    lvl2:   Created surface successfully!
    lvl2:   Loaded fonts successfully.
    lvl2:   Loading system config file...
    lvl1:   System "atari2600" has no games! Ignoring it.
    lvl0:   Error reading config file "/home/pi/.emulationstation/es_systems.cfg" - no equals sign found on line "/home/pi/RetroPie/emulatorcores/stella-libretro/stella_libretro.so --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/atari2600/retroarch.cfg %ROM%""!
    lvl2:   Loading theme "/home/pi/.emulationstation/apple2/theme.xml"...
    lvl2:   Theme loading complete.
    

    #1875
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I will have a look into the DGEN problem within the next days. You need to copy ROMs into the corresponding directories. Emulation Station shows only the systems for which ROM files are available.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar