Problem with n64 emulator

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of matthew798 matthew798 2 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #81299
    Profile photo of matthew798
    matthew798
    Participant

    Hello!

    I have a slight problem with the mupen64plus emulator. When I boot up a rom, it just shows a really low resolution terminal. I couldn’t make any of it out because of the low rez, so i ran a rom from putty on another computer.

    What i THINK is being displayed is:

    Video: Mupen64plus opengl video plugin by rice v2.0.0 – 63.200 VI/S

    So basically that keeps popping up on a new line in the terminal, and i think the last value changes each time.

    I think my problem is that the video is not being initialized properly, or for some reason the full-screen, low rez terminal windows is appearing on top of the emulator.

    Another thing, when i launch a rom from ssh, i get no video (obviously) but i do get sound, and many, MANY audio buffer under run warnings. However when i launch a rom from the emulationstation menus, I get no sound and no buffer under runs.

    Any odeas of how I can get the video working so I can start troubleshooint the million other problems I am bound to have?

    I love the idea of this system and I can’t wait to get it working.

    Thanks!

    #81300
    Profile photo of matthew798
    matthew798
    Participant

    login as: root
    root@192.168.2.11‘s password:
    Linux raspberrypi 3.12.22+ #691 PREEMPT Wed Jun 18 18:29:58 BST 2014 armv6l

    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Fri Sep 26 20:59:04 2014 from 192.168.2.12
    root@raspberrypi:~# cd ..
    root@raspberrypi:/# cd opt/
    root@raspberrypi:/opt# cd retropie
    root@raspberrypi:/opt/retropie# cd emulators
    root@raspberrypi:/opt/retropie/emulators# cd mupen64plus-rpi
    root@raspberrypi:/opt/retropie/emulators/mupen64plus-rpi# ./mupen64plus /home/pi /RetroPie/roms/n64/Supersmash.z64
    -bash: ./mupen64plus: No such file or directory
    root@raspberrypi:/opt/retropie/emulators/mupen64plus-rpi# cd test
    root@raspberrypi:/opt/retropie/emulators/mupen64plus-rpi/test# ./mupen64plus /ho me/pi/RetroPie/roms/n64/Supersmash.z64
    __ __ __ _ _ ____ _
    | \/ |_ _ _ __ ___ _ __ / /_ | || | | _ \| |_ _ ___
    | |\/| | | | | ‘_ \ / _ \ ‘_ \| ‘_ \| || |_| |_) | | | | / __|
    | | | | |_| | |_) | __/ | | | (_) |__ _| __/| | |_| \__ \
    |_| |_|\__,_| .__/ \___|_| |_|\___/ |_| |_| |_|\__,_|___/
    |_| http://code.google.com/p/mupen64plus/
    Mupen64Plus Console User-Interface Version 2.0.0

    UI-Console: attached to core library ‘Mupen64Plus Core’ version 2.0.0
    UI-Console: Includes support for Dynamic Recompiler.
    UI-Console Error: core gave error while setting/unsetting verbose print
    Core: Goodname: Super Smash Bros. (U) [!]
    Core: Name: SMASH BROTHERS
    Core: MD5: F7C52568A31AADF26E14DC2B6416B2ED
    Core: CRC: 916b8b5b 780b85a4
    Core: Imagetype: .z64 (native)
    Core: Rom size: 16777216 bytes (or 16 Mb or 128 Megabits)
    Core: Version: 1449
    Core: Manufacturer: Nintendo
    Core: Country: USA
    UI-Console Status: Cheat codes disabled.
    Video: DEBUG Video-Rice InitConfiguration() 658
    Video: DEBUG Video-Rice set default configuration
    UI-Console: using Video plugin: ‘Mupen64Plus OpenGL Video Plugin by Rice’ v2.0.0
    UI-Console: using Audio plugin: ‘Mupen64Plus OMX Audio Plugin’ v2.0.0
    UI-Console: using Input plugin: ‘Mupen64Plus SDL Input Plugin’ v2.0.0
    UI-Console: using RSP plugin: ‘Hacktarux/Azimer High-Level Emulation RSP Plugin’ v2.0.0
    Video: DEBUG Video-Rice InitConfiguration() 835
    Video: DEBUG Video-Rice set default configuration
    Input: 1 SDL joysticks were found.
    Input: N64 Controller #1: Using auto-config with SDL joystick 0 (‘Logitech Logit ech Dual Action’)
    Input: 1 controller(s) found, 1 plugged in and usable in the emulator
    Input Warning: No rumble supported on N64 joystick #1. features = 0x0 0x0 0x0 0x0
    Input: Mupen64Plus SDL Input Plugin version 2.0.0 initialized.
    Video: Disabled SSE processing.
    Video: Found ROM ‘SMASH BROTHERS’, CRC 5b8b6b91a4850b78-45
    Video: Initializing OpenGL Device Context.
    Video: Using OpenGL: Broadcom – VideoCore IV HW : OpenGL ES 2.0
    Audio: OMX Audio plugin Initialized. Output Frequency 33600 Hz
    Core: Starting R4300 emulator: Dynamic Recompiler
    Core: Init new dynarec
    Audio: OMX Audio plugin Initialized. Output Frequency 32006 Hz
    Audio Warning: Audio Buffer under run(0)

    …..

    Audio Warning: Audio Buffer under run(1790)
    ^C
    root@raspberrypi:/opt/retropie/emulators/mupen64plus-rpi/test# sudo raspi_config
    sudo: raspi_config: command not found
    root@raspberrypi:/opt/retropie/emulators/mupen64plus-rpi/test# sudo raspi-config
    update-rc.d: using dependency based boot sequencing
    update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match switch_cpu_governor Default-Start values (S)
    update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match switch_cpu_governor Default-Stop values (none)

    Broadcast message from root@raspberrypi (pts/0) (Fri Sep 26 21:19:50 2014):
    The system is going down for reboot NOW!
    root@raspberrypi:/opt/retropie/emulators/mupen64plus-rpi/test#

    • This reply was modified 2 years, 6 months ago by Profile photo of matthew798 matthew798.
Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar