Problem configuring joystick and buttons

Home Forums RetroPie Project Everything else related to the RetroPie Project Problem configuring joystick and buttons

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of voltron2112 voltron2112 3 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #1791
    Profile photo of Jonathan Lundström
    Jonathan Lundström


    I have an iPac VE with two joysticks and a lot of buttons connected.
    I’m trying to configure the controls but I get an error using retroarch-joyconfig.

    I start by navigating to:

    Where I run this command:
    ./retroarch-joyconfig -o ~/RetroPie/configs/all/retroarch.cfg

    Unfortunately I don’t get anywhere and the only response I get back is this:
    Couldn't open joystick #0

    I tried search for my issue but all topics are related to using an Xbox 360 controller, which I clearly am trying to use. It would be highly appreciated if anyone could help me get this running.

    Also, I’ve tried adding an ampersand (&) to the command but that does not make things better.

    Thanks in advance,

    Profile photo of voltron2112

    This is what I would try. First type

    jstest /dev/input/js0

    this will let you see what buttons are being pushed on the joystick, so write down what each button number is associated with, and the axis’s of your joystick.

    ctrl-c exits the jstest

    Now you need to edit /RetroPie/configs/all/retroarch.cfg manually with the correct button numbers you found using jstest. Here is an example of mine. The last two lines are so I can press two buttons to exit the emulation.

    input_player1_joypad_index = "0"
    input_player1_a_btn = "0"
    input_player1_b_btn = "1"
    input_player1_y_btn = "3"
    input_player1_x_btn = "2"
    input_player1_start_btn = "7"
    input_player1_select_btn = "6"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_up_axis = "-1"
    input_player1_down_axis = "+1"
    input_player1_left_axis = "-0"
    input_player1_right_axis = "+0"
    #input_player1_l2_btn =
    #input_player1_r2_btn =
    #input_player1_l3_btn =
    #input_player1_r3_btn =
    input_player2_joypad_index = "1"
    input_player2_a_btn = "0"
    input_player2_b_btn = "1"
    input_player2_y_btn = "3"
    input_player2_x_btn = "2"
    input_player2_start_btn = "7"
    input_player2_select_btn = "6"
    input_player2_l_btn = "4"
    input_player2_r_btn = "5"
    input_player2_up_axis = "-1"
    input_player2_down_axis = "+1"
    input_player2_left_axis = "-0"
    input_player2_right_axis = "+0"
    #input_player2_l2_btn =
    #input_player2_r2_btn =
    #input_player2_l3_btn =
    #input_player2_r3_btn =
    input_enable_hotkey_btn = "6"
    input_exit_emulator_btn = "7"

    Attached is the full configuration file in case yours was blank like mine was. Good Luck

    Profile photo of voltron2112

    Apparently you can’t upload .cfg files. Here it is in .txt form.

    1. retroarch.txt
Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar