PPSSPP Controls Issue

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of Omnija Omnija 1 year, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #109175
    Profile photo of Omnija
    Omnija
    Participant

    For some reason most of my buttons are noted as directional buttons. I’m unable to remap the control settings due to this. ab xy directional, directional at L\s and R\s wierd….

    Controller type -> Rock Candy Xbox 360

    #109185
    Profile photo of adid4s
    adid4s
    Participant

    I’m having issues too, I hope someone has a fix for this, I’m using wireless 360 controllers, reicast doesn’t recognize Amy button presses, I just don’t know what the emu.cfg is supposed to look like

    #109227
    Profile photo of xmmer
    xmmer
    Participant

    PPSSPP seems to have its own configuration settings that you can access by pressing the ESC button on a keyboard. I was able to remap controls correctly there. Unfortunately for me, once remapped, the menu registers a constant down press, so the menu becomes unusable afterward. I’m guessing this is part of the “experimental” status of the emulator.

    I couldn’t get Reicast to boot any games at all, so I can’t help you there.

    #109243
    Profile photo of Omnija
    Omnija
    Participant

    When you press (A) button does it show as (A) button when you remap? mine doesn’t, it shows up as Directional buttons and (L) buttons. I also have the menu problem trying to remap as well.

    • This reply was modified 1 year, 5 months ago by Profile photo of Omnija Omnija.
    #109268
    Profile photo of xmmer
    xmmer
    Participant

    No, I’m in the same boat as you – the face buttons map as d-pad, I think the actual d-pad maps as hat switches. It’s incorrect but makes the game side usable, at least. I’m using a Logitech F310 on a Pi 2 with berryboot if it helps with diagnosis, though I suspect the issue is unrelated to hardware.

    #109296
    Profile photo of Omnija
    Omnija
    Participant

    I read somewhere might be mistaken, but it has something to do with it probably being hard coded incorrectly.

    #109508
    Profile photo of Omnija
    Omnija
    Participant

    From this thread it does show that the buttons are hard coded.
    http://forums.ppsspp.org/showthread.php?tid=2108&pid=111910#pid111910

    the method they mentioned does fix the issue, i forked the ppsspp github and made the edit. Change the git link in the retropie ppsspp script and recompiled the emulator. I don’t have the controller issue anymore and i can freely edit my controls without issue.

    • This reply was modified 1 year, 5 months ago by Profile photo of Omnija Omnija.
Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar