Possible script error in RetroPie?

Home Forums RetroPie Project Everything else related to the RetroPie Project Possible script error in RetroPie?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #85867
    Profile photo of Floob
    Floob
    Moderator

    I may well be wrong with this, or doing something wrong, but I think there may be a small error in
    /home/pi/RetroPie-Setup/scriptmodules/supplementary/ps3controller.sh

    In function configure_ps3controller
    it runs a test with sixpair here:
    if ./sixpair | grep -q "Setting master"; then

    but I dont think sixpair is in the path, hence it never runs and the -if- always fails.

    Should it specify the full path of
    /opt/retropie/supplementary/ps3controller
    in order to run sixpair?

    I ask because my setup always fails when I run it, but if I manually run the check with the full path it is fine.

    I am running RetroPie 2.4.1

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85886
    Profile photo of gizmo98
    gizmo98
    Participant

    Could be. I had the same problem with 2.4.1 and replaced sixad driver with a current bluetooth daemon with sixaxis support.
    http://blog.petrockblock.com/forums/topic/using-the-latest-bluez-for-ps3-bluetooth-how-to/
    https://github.com/gizmo98/RetroPie-Setup/blob/bluez/scriptmodules/supplementary/bluez.sh

    I will take a look if sixad runs again with the right path.

    #85888
    Profile photo of Floob
    Floob
    Moderator

    Great, thanks for looking into it.

    Have to say, besides that issue, the setup script worked fine for me. I didnt have to configure or install anything else at all.
    It recognizes the bluetooth device on reboot so is pretty much complete.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #85931
    Profile photo of gizmo98
    gizmo98
    Participant
    #85932
    Profile photo of Floob
    Floob
    Moderator

    Thanks a lot! I’m sure that will sort it out.
    I’ll give the next release a go and see if the script as a whole gets everything up and running in one go.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar