Poor performance running Super Smash Bros. 64? + controller in wrong "slot"

Home Forums RetroPie Project Everything else related to the RetroPie Project Poor performance running Super Smash Bros. 64? + controller in wrong "slot"

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 4 voices, and was last updated by Profile photo of neighbourhoodnerd neighbourhoodnerd 2 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #91568
    Profile photo of haydendavenport
    haydendavenport
    Participant

    Hey all,

    I just got my Raspberry Pi 2, and it’s cool…

    But it’s also hard for me to get things set up!

    I’m having two main issues.

    Issue 1:
    I just put Super Smash Bros. 64 on the device, and got an xbox controller working, but when I ran the game, the first cut scene was stuttering massively. I thought that might just be a cutscene issue, but then I got into the game and there is lag and audio stuttering going on constantly.

    Is that just how this works, or can this be remedied? I read the troubleshooting stuff, but to be honest, it wasn’t step by step so I didn’t understand how to do it (if you have suggestions, please make them step by step for me!).

    Issue 2:
    It seems I can’t get the controller to work for Super Mario Bros. 3 (although it works for Super Smash Bros.). I suspect this has to do with the fact that the Pi is assigning my Xbox controller to slot #2 instead of slot #0. I think this might be the case because when I type “jstest /dev/input/js[0-3]” it says “Joystick (Xbox Gamepad (userspace driver) #2) has 6 axes”

    I know the Snes had to have the first player’s controller in the first port. So.. Is that my problem? If so, I’d love a fix for this as well! ๐Ÿ˜€

    Thank you so much for your help ๐Ÿ™‚

    #91849
    Profile photo of haydendavenport
    haydendavenport
    Participant

    Ok weird, I couldn’t find this post anywhere, even in my thread history, and it suddenly showed up.

    It’s here now though!

    Does anyone know the of potential solutions to my issues?

    #92034
    Profile photo of haydendavenport
    haydendavenport
    Participant

    This thread keeps disappearing and reappearing… Why? O.o

    Anyways, bump!

    #92065
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    Issue 1:
    Support for Nintendo 64 games is a bit patchy. There are two different emulators; each offers better support for different games.

    For example, I have Super Mario 64 and Star Fox 64 running flawlessly, but Banjo Kazooie has blurry text and Banjo Tooie is massively laggy.

    Issue 2:
    In your Retroarch.cfg file, you’ll need to make your joypad have an index of 0. This makes it the “first” controller. If you still want to use your keyboard ingame, give it a higher joypad index.

    input_player1_joypad_index = "0"

    #92069
    Profile photo of haydendavenport2
    haydendavenport2
    Participant

    Neighborhoodnerd,

    Thank you so much for your response! I haven’t been able to use my Pi 2 for like a week because of these issues, but I think I’m on my way to having things running smoothly with your help. ๐Ÿ™‚

    I have two small questions though:
    1. How do I switch between the two emulators?
    2. Would you mind giving me a step by step on how to edit the retroarch.cfg file? Can I edit it using the pi itself, or do I need to use something like CyberDuck?

    Thank you! Seriously. ๐Ÿ™‚

    #92070
    Profile photo of haydendavenport
    haydendavenport
    Participant

    Oops, I had a second account made because I couldn’t get posts to work for a while. Pretend that post ^ was by this account. ๐Ÿ˜›

    #92090
    Profile photo of davejaca
    davejaca
    Participant

    Hayden, make sure you check out the vid below on n64 setup, it might solve some of your problems, Mario and smash should work fine if you tinker, also make sure your overclocked to the Pi 2 setting for best performance, send me a PM if you don’t know how to do this.

    #92130
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    1. There are two different folders for N64 ROMs. Each folder will utilise a different emulator. Note that the non-standard N64 emulator doesn’t use the standard button mappings and often has to be tweaked separately.
    2. You can either edit it via ftp or locally(or SSH) using Nano. If you do it via FTP in Windows, I recommend using Notepad++ to edit the files as Notepad does not lay out the file nicely.

    To edit the file locally:

    sudo nano /opt/retropie/configs/all/retroarch.cfg

    This edits the primary config file and affects all Retroarch Emulators (which is almost all of them).

    Each emulator has its own folder for individual configuration. EG:

    sudo nano /opt/retropie/configs/psx/retroarch.cfg

    The above lets you specify extra config just for the PSX.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar