Player 2 keyboard controls on pifba don't work

Home Forums RetroPie Project Controller Configuration in RetroPie Player 2 keyboard controls on pifba don't work

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of runshadowfaxrun runshadowfaxrun 1 year, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #102470
    Profile photo of retrovortex
    retrovortex
    Participant

    Hey. I’m sure this has come up before, but I need some help in enabling player 2 controls on the keyboard.
    I have set the controls in the fba2x.cfg file but I’m not sure on how one goes about enabling two players on the keyboard.
    (I have one of those IPAC 2 plugged in to my pi via an adapter. I have everything else working fine)
    I swapped the configs around and 1p worked with my 2p buttons so I know its not my setup.
    Do I have to compile a different version of the emulator somewhere? If so how do I go about that?

    • This topic was modified 1 year, 9 months ago by Profile photo of retrovortex retrovortex.

    #102494
    Profile photo of retrovortex
    retrovortex
    Participant

    Don’t worry. I figured it out:

    What you need to do is replace the pifba binary with one that has 2p keyboard enabled.

    Easiest way to do this is to gain root, then use WinSCP to copy the file over and change permissions.

    In order to do that, remotely connect to the pi via PuTTY then put in this line:
    sudo passwd root

    Then set the password to something you remember like “raspberry”

    Once you do that, fire up WinSCP and change your login to root and then the new password.

    Navigate to the /opt/retropie/emulators/pifba folder

    Now download the patched binary from a pifba fork like in this link:
    https://github.com/ian57/Raspicade-configuration-files/blob/master/pifba/fba2x

    Rename the old fba2x file to something like fba2x.backup and then copy the binary you just downloaded over (which you can do now since you are in root).

    Now the final step is to right click the new fba2x binary, go to properties, and change the permissions. You want to click all the X boxes so they have a tick in them. Press OK and now change keyboard keys in the fba2x.cfg file (located at: /opt/retropie/configs/fba/) to whatever you have them programmed as on your IPAC, using this link as a guide:
    http://www.libsdl.org/release/SDL-1.2.15/include/SDL_keysym.h

    And save it, then launch pifba and voila: 2p keyboard controls work!

    • This reply was modified 1 year, 9 months ago by Profile photo of retrovortex retrovortex.
    #105025
    Profile photo of runshadowfaxrun
    runshadowfaxrun
    Participant

    Not sure what I did, but now I can’t authenticate using any known credentials.

    Set the new root pw, logged in and copied across the new file, set permissions and ran a reboot.

    Now my pi says “authentication failure” on boot, and I can’t log in with WinSCP or PuTTY – it doesn’t like my old pi, raspberry or the new root, raspberry.

    Any idea what I did, or how to fix it?

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar