PiTFT and RetroPie = white screen

Home Forums RetroPie Project Everything else related to the RetroPie Project PiTFT and RetroPie = white screen

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 9 replies, has 5 voices, and was last updated by Profile photo of samart45 samart45 1 year, 10 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #97240
    Profile photo of ampersands
    ampersands
    Participant

    I have a Pi 2 and an Adafruit 2.8″ resistive touchscreen.
    I’ve followed this guide on Adafruit:
    https://learn.adafruit.com/running-opengl-based-games-and-emulators-on-adafruit-pitft-displays/overview
    I am reasonably new to this but I feel I have the very basics down.

    Using a clean install of RetroPie 2.6 and then following the guide, I just can’t get it to show anything on the PiTFT other than a white screen.
    I’m using the Framebuffer Copy code as instructed in the guide and still nothing displays on my touchscreen. I don’t receive any errors.
    I know the screen and the Pi work and that I don’t have a hardware problem.

    Has anyone had this problem and managed to resolve it? Does anyone have any advice or better: a working image?

    I’m trying not to get too frustrated with it

    #97253
    Profile photo of ghostwhiper
    ghostwhiper
    Participant

    i’ve got the exact same problem with the pitft 2.8 capacitive.
    did everything correct according to the guide on the adafruit site but the screen stays white,
    hdmi says screen size not suported as it is 320×240.

    tried to doe the source instalation of retropie but even that didnt work.

    /etc/init.d/asplashscreen

    #! /bin/sh
    ### BEGIN INIT INFO
    # Provides:          asplashscreen
    # Required-Start:
    # Required-Stop:
    # Default-Start:     S
    # Default-Stop:
    # Short-Description: Show custom splashscreen
    # Description:       Show custom splashscreen
    ### END INIT INFO
    
    do_start () {
    
        /usr/local/bin/fbcp &
        line=$(head -n 1 /etc/splashscreen.list)
        isMovie=$(echo $line | grep -o "*.mpg")
        if [ -z "$isMovie" ]; then
          /usr/bin/fbi -T 2 -once -t 20 -noverbose -a -l /etc/splashscreen.list &
        else
          mplayer $line &
        fi
        exit 0
    }
    
    case "$1" in
      start|"")
        do_start
        ;;
      restart|reload|force-reload)
        echo "Error: argument '$1' not supported" >&2
        exit 3
        ;;
      stop)
        # No-op
        ;;
      status)
        exit 0
        ;;
      *)
        echo "Usage: asplashscreen [start|stop]" >&2
        exit 3
        ;;
    esac
    
    :
    

    /boot.config.txt

    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # for more options see http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=384
    
    overscan_scale=1
    dtparam=spi=on
    
    # --- added by adafruit-pitft-helper Sun May 10 21:46:15 UTC 2015 ---
    [pi1]
    device_tree=bcm2708-rpi-b-plus.dtb
    [pi2]
    device_tree=bcm2709-rpi-2-b.dtb
    [all]
    dtparam=spi=on
    dtparam=i2c1=on
    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_cvt=320 240 60 1 0 0 0
    hdmi_group=2
    hdmi_mode=87
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # for more options see http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=384
    
    overscan_scale=1
    dtparam=spi=on
    
    # --- added by adafruit-pitft-helper Sun May 10 21:46:15 UTC 2015 ---
    [pi1]
    device_tree=bcm2708-rpi-b-plus.dtb
    [pi2]
    device_tree=bcm2709-rpi-2-b.dtb
    [all]
    dtparam=spi=on
    dtparam=i2c1=on
    dtparam=i2c_arm=on
    dtoverlay=pitft28c,rotate=90,speed=64000000,fps=60
    # --- end adafruit-pitft-helper Sun May 10 21:46:15 UTC 2015 ---
    
    
    pi@retropie ~ $ tail /var/log/messages
    May 11 08:15:53 retropie kernel: [   35.406377] Bluetooth: BNEP socket layer initialized
    May 11 08:15:53 retropie kernel: [   35.443387] Bluetooth: RFCOMM TTY layer initialized
    May 11 08:15:53 retropie kernel: [   35.443468] Bluetooth: RFCOMM socket layer initialized
    May 11 08:15:53 retropie kernel: [   35.443528] Bluetooth: RFCOMM ver 1.11
    May 11 08:15:54 retropie fbcp[2461]: Primary display is 320 x 240
    
    • This reply was modified 1 year, 11 months ago by Profile photo of ghostwhiper ghostwhiper.
    #97255
    Profile photo of trixster
    trixster
    Participant

    Are you running RetroPie 3.0 or later? I cannot help you with RetroPie 2.6.

    I got this to work on a Rpi2 with 3.5″ resistive PiTFT.

    I did not edit /etc/init.d/asplashscreen as it does not exist on my install. Instead I edited /etc/rc.local:
    ————————————–

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will “exit 0” on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    # Print the IP address
    _IP=$(hostname -I) || true
    if [ “$_IP” ]; then
    printf “My IP address is %s\n” “$_IP”
    fi

    /usr/local/bin/fbcp &

    exit 0
    ——————————-

    the end of my config.txt looks like this:

    ————————-
    # — added by adafruit-pitft-helper Wed Apr 15 15:11:37 UTC 2015 —
    [pi1]
    device_tree=bcm2708-rpi-b-plus.dtb
    [pi2]
    device_tree=bcm2709-rpi-2-b.dtb
    [all]
    dtparam=spi=on
    dtparam=i2c1=on
    dtparam=i2c_arm=on
    #dtoverlay=pitft35r,rotate=90,speed=42000000,fps=20
    # — end adafruit-pitft-helper Wed Apr 15 15:11:37 UTC 2015 —

    hdmi_force_hotplug=1
    hdmi_cvt=480 320 60 1 0 0 0
    hdmi_group=2
    hdmi_mode=87

    dtoverlay=pitft35r,rotate=90,speed=80000000,fps=60
    ———————————————-

    You would have to change the “pitft35r” to pitft28r for a resistive screen or pitft28c for a capacative one. You will also need to change the hdmi_cvt line to match your screen’s dimensions.

    It’s probably best not to bump up the fps and speed too much – maybe use the # commented line for dtoverlay rather than the line i’ve added at the end. And DO NOT overclock your core beyond 250Mhz. Mine will not work with any form of core overclock.

    My overclock settings are:

    #uncomment to overclock the arm. 700 MHz is the default.
    arm_freq=1100
    over_voltage=4
    sdram_freq=483
    force_turbo=1

    • This reply was modified 1 year, 11 months ago by Profile photo of trixster trixster.
    #97257
    Profile photo of ghostwhiper
    ghostwhiper
    Participant

    i think fbcp doesnt run properly in my case.
    if i use tail /var/log/messages only the primary display is detected and not the secondary display,

    ampersands what does tail /var/log/messages say with your pi?

    #97259
    Profile photo of trixster
    trixster
    Participant

    pi@RPi2 ~ $ tail /var/log/messages
    May 8 10:17:10 RPi2 kernel: [ 5.094844] bcm2708_spi 3f204000.spi: SPI Contro ller running in dma mode
    May 8 10:17:10 RPi2 kernel: [ 5.102943] bcm2708_i2c_init_pinmode(1,2)
    May 8 10:17:10 RPi2 kernel: [ 5.107612] bcm2708_i2c_init_pinmode(1,3)
    May 8 10:17:10 RPi2 kernel: [ 5.113434] bcm2708_i2c 3f804000.i2c: BSC1 Contr oller at 0x3f804000 (irq 79) (baudrate 100000)
    May 8 10:17:10 RPi2 kernel: [ 6.078649] EXT4-fs (mmcblk0p8): re-mounted. Opt s: (null)
    May 8 10:17:10 RPi2 kernel: [ 6.258898] EXT4-fs (mmcblk0p8): re-mounted. Opt s: (null)
    May 8 10:17:10 RPi2 kernel: [ 6.687723] input: stmpe-ts as /devices/soc/3f20 4000.spi/spi_master/spi0/spi0.1/stmpe-ts/input/input2
    May 8 10:17:10 RPi2 kernel: [ 15.237104] Adding 102396k swap on /var/swap. P riority:-1 extents:1 across:102396k SSFS
    May 8 10:17:11 RPi2 fbcp[2182]: Primary display is 480 x 320
    May 8 10:17:11 RPi2 fbcp[2182]: Second display is 480 x 320 16bps

    #97301
    Profile photo of ghostwhiper
    ghostwhiper
    Participant

    started off again with retropie 2.6 didn’t work, started off with 3.0b2 still white screen.
    Looks like fbcp isn’t running because the secondary display isn’t showing.
    Tried again with both versions and did apt-get update and upgrade but still white screen.
    Tried the resistive drivers instead of capacitive but again the screen stays white.
    started off again with the pitft image and then installed retropie white screen again.

    Installing with hdmi or ssh makes no difference.
    Hdmi is working and retropie boots perfectly at 320×240 Screen resolution.

    • This reply was modified 1 year, 11 months ago by Profile photo of ghostwhiper ghostwhiper.
    #97304
    Profile photo of trixster
    trixster
    Participant

    Do not do apt-get update or apt-get upgrade after the Adafruit kernel has been installed by the helper setup. It breaks the install.

    #97305
    Profile photo of ghostwhiper
    ghostwhiper
    Participant

    I Did update and upgrade after the first boot and controler setup and checked afterwards if retropie was working correctly before I installed the pitft helper.

    maybe it’s a PAL/NTSC problem?
    Not sure if hdmi uses PAL And if fbcp doesn’t work with PAL.

    #99415
    Profile photo of paragon
    paragon
    Participant

    I have the same problem, was a solution ever found?

    #99512
    Profile photo of samart45
    samart45
    Participant

    use dtoverlay parameter to pitft28-resistive on new kernel version
    and check file /boot/overlays/pitft28-resistive-overlay.dtb

    dtoverlay=pitft28-resistive,rotate=90,speed=80000000,fps=60

    Try to test it.

    Reference
    https://github.com/raspberrypi/firmware/tree/master/boot/overlays

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar